Bug 164251 - segfault on startup on x86_64
Summary: segfault on startup on x86_64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: john   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-07-26 09:11 UTC by Noa Resare
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 1.7.0.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 19:59:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autodetect platforms where sizeof(void*) == sizeof(long) (1015 bytes, patch)
2005-07-26 09:11 UTC, Noa Resare
no flags Details | Diff
Fix odd chars and syntax issues (1.17 KB, patch)
2007-02-27 16:52 UTC, Ville Skyttä
no flags Details | Diff

Description Noa Resare 2005-07-26 09:11:30 UTC
Description of problem:

Due to an incorrect assumpution about the size of pointers on the x86_64
platform john segfaults on startup on that platform.

Version-Release number of selected component (if applicable):
john-1.6-4

How reproducible:
always

Steps to Reproduce:
1. unshadow /etc/passwd /etc/shadow > to_crack
2. john to_crack

  
Actual results:

Program received signal SIGSEGV, Segmentation fault.
0x00000000004187d5 in ldr_init_database (db=0x537660, options=0x55a810)
    at loader.c:78
78                      issep_map[(ARCH_INDEX)*pos] = 1;


Expected results:
Some password cracking

Additional info:

The attached patch has been tested on x86_64 and vanilla x86, and I have
verified that it actually cracks simple passwords on both platforms.

I haven't looked into submitting this upstream yet.

Comment 1 Noa Resare 2005-07-26 09:11:30 UTC
Created attachment 117149 [details]
autodetect platforms where sizeof(void*) == sizeof(long)

Comment 2 Gavin Henry 2005-07-26 09:14:17 UTC
Thanks for this report and the patch!!! 

I will test it later this week and get the new RPMS upstream.

Thanks again,

Gavin.

Comment 3 Ville Skyttä 2006-09-23 17:26:01 UTC
Ping?  This still happens in FC5, john-1.6-4.

Comment 4 Gavin Henry 2006-09-23 18:28:12 UTC
Haven't I done this yet? Sorry. Will get on it.

Comment 5 Hans de Goede 2006-11-13 12:45:38 UTC
ping again?


Comment 6 Gavin Henry 2006-11-13 12:48:02 UTC
Should get this nailed this week.

Thanks for your patience.

Gavin.

Comment 7 Gavin Henry 2006-12-05 09:40:24 UTC
Sending for rebuild now.

Comment 8 Ville Skyttä 2006-12-06 12:39:26 UTC
Build failures, looks like it was not even tested if the %prep stage succeeds
(let alone the patched functionality) before submitting the build job :/

http://buildsys.fedoraproject.org/build-status/job.psp?uid=22950
http://buildsys.fedoraproject.org/build-status/job.psp?uid=22951

Comment 9 Gavin Henry 2006-12-06 14:17:27 UTC
Sorry about that. Will test again this week.

Gavin.

Comment 10 Till Maas 2007-01-10 14:50:15 UTC
john 1.7.0.2-2 has been built for development as job 25388

Please check whether or not john works now on x86_64.

Comment 11 Till Maas 2007-02-26 23:44:31 UTC
I will assume the bug is fixed when you do not respond soon.

Comment 12 Ville Skyttä 2007-02-27 07:53:39 UTC
Well, the package is not available in the devel x86_64 repo.

Comment 13 Till Maas 2007-02-27 08:37:14 UTC
The buildsystem told me the build succeeded, what can I do now?

http://buildsys.fedoraproject.org/build-status/job.psp?uid=25388

Comment 14 Ville Skyttä 2007-02-27 16:52:08 UTC
Created attachment 148873 [details]
Fix odd chars and syntax issues

Dunno, but the binary package is missing from the ppc repository too, ditto in
the FC-6 repo.	Before doing anything else, I'd suggest taking a look at these
findings:

There seems to be an odd character of some kind on lines 64 and 83, the "%"
preceding {target_mmx} is not a regular percent sign - I suppose that will
cause some problems.

There is also syntactic problems in the specfile on line 47 (and I suppose on
line 64 and 85 too, they're essentially the same as line 47 after the percent
sign problem has been corrected) when eval'd on x86_64:

$ rpm -q --specfile john.spec
error: syntax error in expression
error: john.spec:47: parseExpressionBoolean returns -1

The attached patch should fix all these issues.  And looks like a local x86_64
FC6 build no longer crashes.

Comment 15 Till Maas 2007-02-27 19:52:52 UTC
I applied your patch, the build succeeded, I hope it will be published, too:

http://buildsys.fedoraproject.org/logs/fedora-development-extras/28366-john-1.7.0.2-3.fc7/

Comment 16 Ville Skyttä 2007-02-27 21:32:49 UTC
Looks good so far, at least all binary packages are in the needsign queue as
expected.  The FC6 branch needs the fix too, BTW.

Comment 17 Till Maas 2007-03-01 19:59:24 UTC
(In reply to comment #16)
> Looks good so far, at least all binary packages are in the needsign queue as
> expected.  The FC6 branch needs the fix too, BTW.

FC6 has been rebuilt, too.


Note You need to log in before you can comment on or make changes to this bug.