Bug 164260 - Ctrl+Alt+BackSpace Don't Work Restart X Just Freeze PC
Summary: Ctrl+Alt+BackSpace Don't Work Restart X Just Freeze PC
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-26 13:17 UTC by Bernardino
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 15:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernardino 2005-07-26 13:17:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
After the Upgrade X just did not work just a White Screen Show. After update to the latest version of Xorg and read the Bugzilla commit 2 changes in the Xorg.conf
0.- Run Xorg -configure and copy the result to /etc/X11/xorg.conf
1.- replace /dev/mouse by /dev/mouse0
2.- Change the driver form "Trident" to "vesa" 

The Start X work ok. If I logout ok from GUI not a problem or restart but if:
Ctrl+Alt+BackSpace Don't Work Restart X Just Freeze PC. Need to reboot.

I wonder if there is some extra change in xorg.conf to allow X restart on Ctrl+Alt+BackSpace.

Version-Release number of selected component (if applicable):
Xorg

How reproducible:
Always

Steps to Reproduce:
1.Upgrade To FC4
2.Change Driver to Vesa and mouse to /dev/mouse0
3.Try to restart X using the Keyboard Ctrl+Alt+BackSpace
  

Actual Results:  The computer just freeze and not start X just like a regular boot.

Expected Results:  Return to the GUI X Login page of Fedora.

Additional info:

Comment 1 Olivier Baudron 2005-07-29 10:07:06 UTC
What is your video card ?
When X is running, can you switch to a virtual console with CTRL-ALT-F2 ?

Comment 2 Bernardino 2005-07-29 13:55:09 UTC
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "glx"
        Load  "dbe"
        Load  "extmod"
        Load  "record"
        Load  "xtrap"
        Load  "type1"
        Load  "freetype"
        Load  "dri"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/mouse0"
EndSection

Section "Monitor"

        #DisplaySize      360   270     # mm
        Identifier   "Monitor0"
        VendorName   "VSC"
        ModelName    "E790"
        HorizSync    30.0 - 95.0
        VertRefresh  50.0 - 200.0
        Option      "DPMS"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "PciRetry"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SetMClk"                   # <freq>
        #Option     "MUXThreshold"              # <i>
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "NoMMIO"                    # [<bool>]
        #Option     "NoPciBurst"                # [<bool>]
        #Option     "MMIOonly"                  # [<bool>]
        #Option     "CyberShadow"               # [<bool>]
        #Option     "CyberStretch"              # [<bool>]
        #Option     "XvHsync"                   # <i>
        #Option     "XvVsync"                   # <i>
        #Option     "XvBskew"                   # <i>
        #Option     "XvRskew"                   # <i>
        #Option     "FpDelay"                   # <i>
        #Option     "Display1400"               # [<bool>]
        #Option     "Display"                   # [<str>]
        #Option     "GammaBrightness"           # [<str>]
        #Option     "TVChipset"                 # [<str>]
        #Option     "TVSignal"                  # <i>
        #Driver      "trident"
        Identifier  "Card0"
        Driver      "vesa"
        VendorName  "Trident Microsystems"
        BoardName   "CyberBlade/i1"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "800x600" "640x480"
        EndSubSection
EndSection

########################################

Yes I switch to Text Mode Console but can't Reset X using Ctl+Alt+BackSpace

Comment 3 Olivier Baudron 2005-07-29 14:20:53 UTC
Cyberblade is known to have an issue with the last Xorg update.
Can you upgrade to
http://people.redhat.com/krh/xorg-x11-6.8.2-44
and tell me if it works for you.

Comment 4 Olivier Baudron 2005-07-29 15:43:25 UTC
Your problem is fixed in rawhide now:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/

Comment 5 Olivier Baudron 2005-07-29 15:45:35 UTC

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.