Bug 1642745 - Error when using `oc run` with attach against a deployment config
Summary: Error when using `oc run` with attach against a deployment config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 01:48 UTC by Clayton Coleman
Modified: 2019-06-04 10:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: DeploymentConfig was not properly recognized type when attaching to an object. Consequence: Attaching to a deployment config was not possible. Fix: Implement deploymentconfig support. Result: oc run works when trying to attach to a deployment config.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:58 UTC

Description Clayton Coleman 2018-10-25 01:48:11 UTC
$ oc run -it debug --image centos:7
error: cannot attach to *v1.DeploymentConfig: selector for *v1.DeploymentConfig not implemented

This should have a selector implemented, or return a better error (probably the former).

Happened in master but we need to check against 3.11.

Comment 1 Xingxing Xia 2018-10-26 04:36:44 UTC
Can reproduce with
# oc version
oc v3.11.31
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://xxx:8443
openshift v3.11.31
kubernetes v1.11.0+d4cacc0

oc run -it debug --image centos:7
error: cannot attach to *v1.DeploymentConfig: selector for *v1.DeploymentConfig not implemented

oc run -i debug1 --image centos:7
error: cannot attach to *v1.DeploymentConfig: selector for *v1.DeploymentConfig not implemented

Pods are running, though:
oc get po
NAME             READY     STATUS             RESTARTS   AGE
debug-1-d7zk4    1/1       Running            0          5m
debug1-1-z25l8   1/1       Running            0          4m

Comment 2 Juan Vallejo 2018-10-26 20:19:16 UTC
Origin PR: https://github.com/openshift/origin/pull/21367

Comment 3 Juan Vallejo 2018-10-29 18:15:29 UTC
Origin PR has merged.

Comment 5 Xingxing Xia 2018-12-03 02:16:56 UTC
Verified in v4.0.0-0.80.0. Now `oc run -i` works.
[root@ip-172-18-0-211 ~]# oc run -it debug --image centos:7
If you don't see a command prompt, try pressing enter.
bash-4.2$ exit
Session ended, resume using 'oc attach debug-1-gbw6b -c debug -i -t' command when the pod is running
[root@ip-172-18-0-211 ~]# oc run -i debug1 --image centos:7
If you don't see a command prompt, try pressing enter.
^C

Comment 6 Max Whittingham 2018-12-07 20:04:40 UTC
Is this something that could get backported to 3.11?

Comment 7 Juan Vallejo 2018-12-07 21:17:59 UTC
PR backporting this to 3.11: https://github.com/openshift/origin/pull/21634

Comment 11 errata-xmlrpc 2019-06-04 10:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.