Bug 1642768 - Blank screen on boot and login session using 4.19.0-1
Summary: Blank screen on boot and login session using 4.19.0-1
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 29
Hardware: x86_64 Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 03:34 UTC by Luya Tshimbalanga
Modified: 2018-10-29 19:08 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-29 19:08:25 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Journal report (160.76 KB, text/plain)
2018-10-25 03:34 UTC, Luya Tshimbalanga
no flags Details
journal boot report using kernel 4.19.0 (216.20 KB, text/plain)
2018-10-26 05:04 UTC, Luya Tshimbalanga
no flags Details
boot report with kernel-4.19.0 on fresh installation (244.63 KB, text/plain)
2018-10-28 06:08 UTC, Luya Tshimbalanga
no flags Details

Description Luya Tshimbalanga 2018-10-25 03:34:47 UTC
Created attachment 1497277 [details]
Journal report

Description of problem:
Booting with kernel 4.19.0-1 on AMD based laptop (tested on HP Envy x360 Ryzen 5) and possibly other hardware led to a blank screen.

Version-Release number of selected component (if applicable):
4.19.0-1

How reproducible:
Always

Steps to Reproduce:
1. Boot with kernel 4.19.0
2.
3.

Actual results:
Blank screen

Expected results:
Boot normally into login session

Additional info:
Tested for https://fedoraproject.org/wiki/QA:Testcase_kernel_regression

Comment 1 Jeremy Cline 2018-10-25 17:46:41 UTC
Hi Luya,

The complete journal doesn't appear to be attached, so I don't know what kernel is actually being booted here, but I see there's something in the logs about a DKMS build for amdgpu against 4.18.14.

Can you reproduce this on a fresh install and attach the complete logs if so ("journalctl --no-hostname -b 0" should do it)?

Comment 2 Luya Tshimbalanga 2018-10-26 05:04 UTC
Created attachment 1497629 [details]
journal boot report using kernel 4.19.0

That is strange. On livemedia, the boot looks fine but I am unable to pick the journal boot report on post installation. Possibly due to the migration of data from HDD to SSD.
I attempt to vainly use external HDD that used to be part on my laptop, HP Envy x360 Ryzen 2500u. Not sure why it failed.

Comment 3 Luya Tshimbalanga 2018-10-26 05:10:46 UTC
ACPI error in the kernel broke both touchscreen and stylus support as seen on https://bugzilla.kernel.org/show_bug.cgi?id=198715

Comment 4 Luya Tshimbalanga 2018-10-28 06:08 UTC
Created attachment 1498226 [details]
boot report with kernel-4.19.0 on fresh installation

It looks like the fresh install resolved the issue.

Comment 5 Luya Tshimbalanga 2018-10-29 19:08:25 UTC
Closing this report as I noticed no further issue since fresh installation.


Note You need to log in before you can comment on or make changes to this bug.