Bug 16428 - SDL crashes, maybe new glibc fault?
SDL crashes, maybe new glibc fault?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-17 07:38 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 11:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple test case which segfaults (499 bytes, application/octet-stream)
2000-08-17 08:52 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-08-17 07:38:55 EDT
Hi, I encountered a strange problem.

Every program which uses SDL_mixer segfaults (I think its also maybe every
program which uses SDL and sound). I debugged one with the
following result.
SDL_Init works, but after calling
      if (Mix_OpenAudio(22050, AUDIO_S16, 2, 256) < 0)
it immediately segfaults.
following message:
[New Thread 2049 (LWP 31136)]
[New Thread 1026 (LWP 31137)]

Program received signal SIGSEGV, Segmentation fault.
__pthread_unlock (lock=0x8052f78)

But there was now problem with Redhat 6.2. I think it seems to be a problem
with the new glibc? Any workaround available (like using the old glibc?)

Thanks,

Marcus
Comment 1 Jakub Jelinek 2000-08-17 08:11:06 EDT
My suspicion is that SDL tries to unlock an already unlocked mutex.
Can you tell me which exact program you can reproduce that behaviour with
(I cannot find Mix_OpenAudio in SDL).
Comment 2 Need Real Name 2000-08-17 08:52:16 EDT
Created attachment 2586 [details]
simple test case which segfaults
Comment 3 Bill Nottingham 2000-08-17 11:09:46 EDT
I can't reproduce this here on a test system; it
runs OK.
Comment 4 Need Real Name 2000-08-18 08:08:14 EDT
you're right after changing back to sdl-1.1.3 from the pinstripe distro it works
flawlessly (i tried with sdl-1.1.4). But my problem with pinstripe isn't solved
yet. XMPS with avi plugin does work under redhat 6.2, but not with pinstripe and
somehow the sdl sound is related to the problem. (this sound problem also occurs
with sdl-1.1.3). Maybe I can build a new test case.

Note You need to log in before you can comment on or make changes to this bug.