Bug 1642800 - socket: log voluntary socket close/shutdown and EOF on socket at INFO log-level
Summary: socket: log voluntary socket close/shutdown and EOF on socket at INFO log-level
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: transport
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 06:11 UTC by Milind Changire
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21665 0 None Open Revert \"transport: log socket closures more verbose\" 2018-11-16 11:58:02 UTC

Description Milind Changire 2018-10-25 06:11:55 UTC
Description of problem:
there's no way to identify between intentional and unintentional socket closure

Expected results:
logs at INFO log level helps identify voluntary socket closure

Additional info:

Comment 1 Worker Ant 2018-10-26 04:07:39 UTC
COMMIT: https://review.gluster.org/21481 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- transport: log socket closures more verbose

Problem:
Intentional and unintentional socket closures cannot be identified

Solution:
Log intentional socket closures with at least INFO log level

Change-Id: Ic02c882b16ab2193e57f8c3e6c3a82c4fe0f6875
fixes: bz#1642800
Signed-off-by: Milind Changire <mchangir@redhat.com>

Comment 2 Worker Ant 2018-11-16 11:58:01 UTC
REVIEW: https://review.gluster.org/21665 (Revert \"transport: log socket closures more verbose\") posted (#1) for review on master by Milind Changire

Comment 3 Shyamsundar 2019-03-25 16:31:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.