Bug 1642854 - glusterd: raise default transport.listen-backlog to 1024
Summary: glusterd: raise default transport.listen-backlog to 1024
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.4.z Batch Update 2
Assignee: Milind Changire
QA Contact: Rochelle
URL:
Whiteboard:
Depends On: 1642850
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 08:38 UTC by Milind Changire
Modified: 2018-12-19 07:07 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.12.2-27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1642850
Environment:
Last Closed: 2018-12-17 17:07:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3827 0 None None None 2018-12-17 17:07:27 UTC

Description Milind Changire 2018-10-25 08:38:17 UTC
+++ This bug was initially created as a clone of Bug #1642850 +++

Description of problem:
data center setups with large number of bricks with replication causes a flood of connections to glusterd causing connections to be dropped due to insufficient backlog queue length

Version-Release number of selected component (if applicable):


How reproducible:
frequently

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
connections to glusterd should not be dropped or refused

Additional info:

Comment 2 Atin Mukherjee 2018-10-25 08:49:48 UTC
This was seen in ENEL setup.

Comment 3 Milind Changire 2018-10-25 09:05:34 UTC
upstream patch: https://review.gluster.org/c/glusterfs/+/21482

Comment 12 errata-xmlrpc 2018-12-17 17:07:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3827


Note You need to log in before you can comment on or make changes to this bug.