Bug 164290 - joe segfaults on startup
joe segfaults on startup
Status: CLOSED DUPLICATE of bug 157702
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: joe (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 12:47 EDT by Bill Nottingham
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 03:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this (286 bytes, patch)
2005-07-26 12:57 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2005-07-26 12:47:36 EDT
Description of problem:

joe crashes on startup.

Version-Release number of selected component (if applicable):

3.1-6

How reproducible:

Every time

Steps to Reproduce:
1. Run joe

Actual results:

Program received signal SIGSEGV, Segmentation fault.
0x2000000000205aa0 in strlen () from /lib/tls/libc.so.6.1
(gdb) bt
#0  0x2000000000205aa0 in strlen () from /lib/tls/libc.so.6.1
#1  0x20000000000b0490 in tparm (
    string=0x300b2 <Address 0x300b2 out of bounds>)
    at ../../ncurses/tinfo/lib_tparm.c:495
#2  0x20000000000af6e0 in tgoto (
    string=0x300b2 <Address 0x300b2 out of bounds>, x=0, y=0)
    at ../../ncurses/tinfo/lib_tgoto.c:201
#3  0x4000000000041ea0 in texec (cap=0x600000000002d0e0,
    s=0x300b2 <Address 0x300b2 out of bounds>, l=0, a0=0, a1=0, a2=0, a3=0)
    at termcap.c:518
#4  0x4000000000042c50 in tcompile (cap=0x600000000002d0e0,
    s=0x300b2 <Address 0x300b2 out of bounds>, a0=0, a1=0, a2=0, a3=0)
    at termcap.c:708
#5  0x400000000001da20 in kbuild (cap=0x600000000002d0e0,
    kmap=0x6000000000036ac0, seq=0x60000fffffffb2f6 ".kN",
    bind=0x600000000003ba70, err=0x60000fffffffb2e0,
    capseq=0x60000fffffffb2f9 "", seql=0) at kbd.c:224
#6  0x400000000001dba0 in kadd (cap=0x600000000002d0e0,
    kmap=0x6000000000036ac0, seq=0x60000fffffffb2f6 ".kN",
    bind=0x600000000003ba70) at kbd.c:275
#7  0x400000000002d500 in procrc (cap=0x600000000002d0e0,
    name=0x6000000000032378 "/etc/joe/joerc") at rc.c:1001
#8  0x4000000000021f60 in main (argc=1, argv=0x60000fffffffb9b8,
    envv=0x60000fffffffb9c8) at main.c:274
#9  0x20000000001554b0 in __libc_start_main () from /lib/tls/libc.so.6.1
#10 0x40000000000030c0 in _start ()

Expected results:


Additional info:
Comment 1 Bill Nottingham 2005-07-26 12:57:41 EDT
Created attachment 117164 [details]
patch to fix this
Comment 2 Bill Nottingham 2005-07-26 12:58:15 EDT
Fixing arch on the bug.
Comment 3 Ivana Varekova 2005-07-27 03:27:03 EDT

*** This bug has been marked as a duplicate of 157702 ***

Note You need to log in before you can comment on or make changes to this bug.