Bug 164293 - boot fails because of usb hard drive (hdd) entry in /etc/fstab
Summary: boot fails because of usb hard drive (hdd) entry in /etc/fstab
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-26 17:09 UTC by Joseph Shraibman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 14:27:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Shraibman 2005-07-26 17:09:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I have this entry in /etc/fstab for my usb hard drive

/dev/sda1              /mnt/usb-hdd                ext3    user,noauto        0 1

The problem is that after I upgraded to the latest kernel my computer refuses to boot.  When mounting filesystems it complains about an invalid device (can't cut and paste the 

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Put the above line in your /etc/fstab
2.
3.
  

Actual Results:  During boot it complained about an invalid device.  It then dropped me to a root shell and rebooted after I left the root shell.  I had to comment out the line in /etc/fstab

Expected Results:  boot should have continued.  The mount point was noauto

Additional info:

I'm pretty sure this bug happened after I upgraded kernels, but I'm not sure.  It could be something else I upgraded.  The machine in question is headless so I can't easily play around rebooting it with different kernels.

Comment 1 Joseph Shraibman 2005-07-27 14:27:44 UTC
never mind, this bug is not a regression.  It was caused by the 1 in the last
fstab field. 


Note You need to log in before you can comment on or make changes to this bug.