Bug 1643051 - Dragging Activity dock icon for a few seconds causes session to crash
Summary: Dragging Activity dock icon for a few seconds causes session to crash
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 12:28 UTC by Daniel Rusek
Modified: 2019-11-27 19:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 19:38:35 UTC
Type: Bug


Attachments (Terms of Use)
systemd-coredump log of the crash (15.41 KB, application/octet-stream)
2018-10-25 14:36 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2018-10-25 12:28:32 UTC
Description of problem:
When some icon from the GNOME Activities Overview dock is dragged around for a few (~5 and more) seconds, the gnome-shell process crashes with coredump and if you are on Wayland also causes the whole session to crash. This does not seem to happen on older (3.28) GNOME Shell versions, just the 3.30 one.

Version-Release number of selected component (if applicable):
gnome-shell-3.30.1-2.fc29.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Open the Activities Overview window.
2. Try to drag any icon in the running/favourite applications dock for five seconds or longer.

Additional info:
https://gitlab.gnome.org/GNOME/gnome-shell/issues/632

Comment 1 Fedora Blocker Bugs Application 2018-10-25 12:37:10 UTC
Proposed as a Blocker for 29-final by Fedora user zlopez using the blocker tracking app because:

 This bug is causing crash of whole gnome session in certain circumstances, which leads to loss of every currently opened work.

Comment 2 František Zatloukal 2018-10-25 13:28:33 UTC
Cannot reproduce, can you also tell me what's your mutter version and active extensions (if you have any, can you disable them)?

Thanks!

Comment 3 Kamil Páral 2018-10-25 13:29:06 UTC
I tried testing on bare metal and in VM, using X11 and Wayland, and it doesn't crash for me. I have:
gnome-shell-3.30.1-2.fc29.x86_64
mutter-3.30.1-5.fc29.x86_64

Daniel, what mutter version do you have? Do you have any extensions installed? If you do, please try disabling all of them and reboot.

Comment 4 Michal Konecny 2018-10-25 14:21:02 UTC
I reproduced this on latest Fedora Silverblue - 29.20181021.n.0.
gnome-shell-3.30.1-1.fc29.x86_64
mutter-3.30.1-2.fc29.x86_64

I dragged icon from dock and moved it around dock for 20 seconds and the session crashed on Wayland.

This is in VM and with fresh installation with updates.

Comment 5 Daniel Rusek 2018-10-25 14:36:19 UTC
It seems that it happens only for icons that are in favourites. The quicker the icon is moved, the earlier the crash happens. My mutter version: mutter-3.30.1-5.fc29.x86_64

I am including a backtrace log from systemd-coredump.

Someone also provided a complete stacktrace and backtrace here: https://gitlab.gnome.org/GNOME/gnome-shell/issues/632#note_341263

Comment 6 Daniel Rusek 2018-10-25 14:36:50 UTC
Created attachment 1497494 [details]
systemd-coredump log of the crash

Comment 7 Daniel Rusek 2018-10-25 14:42:50 UTC
I reproduced this on both Wayland and Xorg.

Comment 8 Geoffrey Marr 2018-10-25 15:05:01 UTC
I cannot reproduce this on baremetal.

gnome-shell-3.30.1-2.fc29.x86_64
mutter-3.30.1-5.fc29.x86_64

I have tried dragging icons in the favorites bar, both currently running and not running, as well as icons in the App Overview, but cannot get the system to crash.

Comment 9 Geoffrey Marr 2018-10-25 17:13:25 UTC
Discussed during the 2018-10-25 Fedora 29 Final Go/No-Go meeting:

The decision to classify this bug as a “RejectedBlocker” was made as several testers are unable to reproduce this issue and it's not clear that it falls under the umbrella of "basic operation" for blocker criteria.

Comment 10 Daniel Rusek 2018-10-25 17:20:53 UTC
I was trying it only in VM, but the one who provided the backtrace/stacktrace in the upstream bug report (see #c5) reproduced this on physical hw with NVIDIA GPU.

Comment 11 Zbigniew Jędrzejewski-Szmek 2018-10-25 20:08:31 UTC
Doesn't seem to happen here on bare metal with Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07).

Comment 12 Grey Nicholson 2018-10-26 02:29:56 UTC
I can reproduce this using X11 in Silverblue 29.20181022.n.1 on a Lenovo ThinkPad X230 (not a VM).

I dragged a running favourite app's icon, quickly up and down across the dash. I was trying to make the position marker appear and disappear quickly.

The first 2 times, after about 20 seconds, the Shell crashed and restarted. The 3rd time, it only took about 3 seconds, and the whole session crashed; I had to log back into a new session.

Comment 13 Ben Cotton 2019-10-31 20:37:27 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 14 Ben Cotton 2019-11-27 19:38:35 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.