Bug 1643183 - On satellite 6.4, foreman-proxy service fails to start if IPv6 is disabled
Summary: On satellite 6.4, foreman-proxy service fails to start if IPv6 is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.4
Hardware: x86_64
OS: Linux
urgent
high vote
Target Milestone: 6.4.2
Assignee: Evgeni Golov
QA Contact: Perry Gagne
URL:
Whiteboard:
: 1643177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-25 17:01 UTC by Prakash Ghadge
Modified: 2019-10-30 19:28 UTC (History)
14 users (show)

Fixed In Version: foreman-installer-1.18.0.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 19:08:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 25460 High Closed foreman-proxy service fails to start if IPv6 is disabled 2020-05-27 13:08:40 UTC
Red Hat Knowledge Base (Article) 3667001 None None None 2018-10-25 17:25:23 UTC
Red Hat Product Errata RHBA-2019:0345 None None None 2019-02-13 19:08:25 UTC

Internal Links: 1746321

Comment 1 Prakash Ghadge 2018-10-25 17:01:58 UTC
Also check - https://bugzilla.redhat.com/show_bug.cgi?id=1643177

Comment 2 Prakash Ghadge 2018-10-25 17:18:36 UTC
Description of problem:

On satellite 6.4, foreman-proxy service fails to start if IPv6 is disabled

Version-Release number of selected component (if applicable):

Satellite 6.4.0

How reproducible:

Always

Steps to Reproduce:
1. Build a Satellite 6.4
2. Disable the IPv6 using the following article.

https://access.redhat.com/solutions/8709

3. Reboot the system and run "# katello-service restart"

Actual results:

foreman-proxy service fails to start

Expected results:

foreman-proxy should start

Additional info:

journalctl log for foreman-proxy:

-- Logs begin at Fri 2018-10-19 12:36:58 MDT, end at Fri 2018-10-19 13:14:57 MDT. --
Oct 19 13:14:56 satellite.example.com systemd[1]: Starting Foreman Proxy...
Oct 19 13:14:57 satellite.example.com  smart-proxy[24755]: Running Foreman Ansible Core in non-SCL context
Oct 19 13:14:57 satellite.example.com  smart-proxy[24755]: Errors detected on startup, see log for details. Exiting: Address fa
mily not supported by protocol - socket(2)
Oct 19 13:14:57 satellite.example.com  systemd[1]: foreman-proxy.service: main process exited, code=exited, status=1/FAILURE
Oct 19 13:14:57 satellite.example.com  systemd[1]: Failed to start Foreman Proxy.
Oct 19 13:14:57 satellite.example.com  systemd[1]: Unit foreman-proxy.service entered failed state.
Oct 19 13:14:57 satellite.example.com  systemd[1]: foreman-proxy.service failed.

Comment 3 Brad Buckingham 2018-10-26 15:18:50 UTC
*** Bug 1643177 has been marked as a duplicate of this bug. ***

Comment 8 Ewoud Kohl van Wijngaarden 2018-11-13 16:16:21 UTC
This was introduced in 77ed56fb0392f8c5f0fec094ccc422b98f2f62fb which changed the bind host to :: instead of *. If the IPv6 kernel module is disabled then you can't listen on ::. The workaround is to listen on * again by rerunning the installer with:

  --foreman-proxy-bind-host '*'

Note that you must quote the * because the shell will expand it otherwise.

The long term solution is adding a migration and/or check to the installer that does this automatically for the user.

Comment 11 Chris Zinda 2018-11-13 17:56:32 UTC
Confirmed on my system that Ewound's workaround in c8 does indeed resolve the issue.

Thanks!

Comment 12 Evgeni Golov 2018-11-14 11:45:39 UTC
Created redmine issue https://projects.theforeman.org/issues/25460 from this bug

Comment 13 pm-sat@redhat.com 2018-11-14 13:03:21 UTC
Upstream bug assigned to egolov@redhat.com

Comment 14 pm-sat@redhat.com 2018-11-14 13:03:26 UTC
Upstream bug assigned to egolov@redhat.com

Comment 15 pm-sat@redhat.com 2018-12-07 13:03:13 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/25460 has been resolved.

Comment 19 Perry Gagne 2019-01-23 18:52:28 UTC
Verified fix in 6.4.2 snap 1

1. Disabled IPv6 using the ipv6.disable kernel flag method from https://access.redhat.com/solutions/8709
2. Removed IPv6 entries (including localhost) from /etc/hosts
3. ran "satellite-installer --scenario satellite -v"

The install was successful and foreman-proxy started.

Comment 22 errata-xmlrpc 2019-02-13 19:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0345


Note You need to log in before you can comment on or make changes to this bug.