Bug 164327 - ooo calc import csv dialog box: screwed up for fixed with columns
ooo calc import csv dialog box: screwed up for fixed with columns
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 18:26 EDT by Gregory Zornetzer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.121-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 05:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fontconfig demo source (4.78 KB, text/x-csrc)
2005-07-27 07:22 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Gregory Zornetzer 2005-07-26 18:26:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I try to import a text file with fixed width columns, the "Text Import" dialog box misbehaves.  If I select the "Fixed width" separator option, and then try to put in my own separators using the mouse to click on the little ruler in the preview window, I see additional characters being added into the preview window.  Somehow, selecting a separator is changing the data on the lines.  It looks like existing data is being copied.
FYI, I'm fairly sure that this problem did not occur with the older openoffice.org that came with fedora core 4.

Version-Release number of selected component (if applicable):
openoffice.org-calc-1.9.117-3.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.Create a text file with data in columns, separated by spaces (do it in a fixed-width font for easiest viewing of the columns)
2.Save the text file with a .csv extension
3.Read the file with ooo calc
4.In the Text Import dialog box, select the fixed width separator option and click somewhere in the "ruler" area to make your own separator. 
  

Actual Results:  A grey line appears below where you clicked on the ruler.  A portion of the text in the preview box will be duplicated.  Some of the text will shift.

Expected Results:  A grey line should appear.  No text should move or be copied.

Additional info:

I can provide screenshots if it would help.  However, the bug is pretty trivial to reproduce (for me)
Comment 1 Caolan McNamara 2005-07-27 07:22:37 EDT
Created attachment 117185 [details]
fontconfig demo source
Comment 2 Caolan McNamara 2005-07-27 09:07:13 EDT
the font isn't a monospaced font, this is because fontconfig apparently doesn't
take that property into account the way I thought it would.

Note You need to log in before you can comment on or make changes to this bug.