Bug 1643519 - Provide an option to silence glfsheal logs
Summary: Provide an option to silence glfsheal logs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1579293 1654229 1654236
TreeView+ depends on / blocked
 
Reported: 2018-10-26 12:43 UTC by Ravishankar N
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1654229 1654236 (view as bug list)
Environment:
Last Closed: 2019-03-25 16:31:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21501 0 None Merged glfsheal: add a '--nolog' flag 2018-11-26 08:36:52 UTC

Description Ravishankar N 2018-10-26 12:43:25 UTC
Description of problem:

Many monitoring/reporting solutions run 'gluster volume heal $volname info' and its related subcommands very frequently (even once every minute), leading to unnecessary filling up of the glfsheal logs. (See downstream BZs 1579293 and 1631851 for instance). The main intention of running these commands is to process/consume the output displayed on stdout/xml format and not really the gluster client logs which glfsheal (which is gfapi based) generates under /var/log/glusterfs/glfsheal*.

Hence it is useful to have a --nolog option which will prevent the incessant logging. 

Note that these logs are VERY helpful when debugging when heal-info is unresponsive/hung/disconnected from bricks or when running split-brain resolution commands. So the default log level is still kept at GF_LOG_INFO and is changed to GF_LOG_NONE only when the command is invoked with the --nolog flag.

Comment 1 Worker Ant 2018-10-26 12:46:03 UTC
REVIEW: https://review.gluster.org/21501 (glfsheal: add a '--nolog' option) posted (#1) for review on master by Ravishankar N

Comment 2 Worker Ant 2018-11-26 08:36:51 UTC
REVIEW: https://review.gluster.org/21501 (glfsheal: add a '--nolog' flag) posted (#5) for review on master by Pranith Kumar Karampuri

Comment 3 Shyamsundar 2019-03-25 16:31:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.