Bug 1643664 - texlive-scheme-full installation failure
Summary: texlive-scheme-full installation failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1634313 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-26 23:58 UTC by Kyriakos Fytrakis
Modified: 2018-11-05 02:01 UTC (History)
9 users (show)

Fixed In Version: texlive-2018-21.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-05 02:01:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Kyriakos Fytrakis 2018-10-26 23:58:51 UTC
Description of problem:
Trying to install texlive-scheme-full through dnf in a fresh installed Fedora. Output error:
Error: 
 Problem: package texlive-scheme-full-8:svn44177-20.fc29.noarch requires texlive-collection-binextra, but none of the providers can be installed
  - conflicting requests
  - nothing provides texlive-xindy needed by texlive-collection-binextra-8:svn47945-20.fc29.noarch

Version-Release number of selected component (if applicable): 20.fc29


How reproducible: Try to install the package via terminal.


Steps to Reproduce:
1.
2.
3.

Actual results:
Installation failure.

Expected results:
Installation success.

Additional info:

Comment 1 Basil Eric Rabi 2018-10-31 11:27:04 UTC
*** Bug 1634313 has been marked as a duplicate of this bug. ***

Comment 2 Kyriakos Fytrakis 2018-10-31 13:26:43 UTC
Something I forgot to mention in the original message. Basically, there is no package "texlive-xindy" in the repositories.

Comment 3 Than Ngo 2018-10-31 13:41:27 UTC
xindy was disable because xindy_arches was set to empty. It's fixed in 8:2018-21. Maybe we need to define xindy_arches in rpm texlive macro or in specfile.

Comment 4 Tom "spot" Callaway 2018-10-31 13:55:06 UTC
xindy_arches was set to empty because the xindy code is extremely fragile and only builds on 1 out of every 5 or 6 attempts through koji.

Comment 5 Rick Lee 2018-10-31 14:01:26 UTC
I am experiencing this problem is well. Is there a workaround until the packaging can get sorted out?

Comment 6 Fedora Update System 2018-11-02 15:27:54 UTC
texlive-2018-21.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2478e665fd

Comment 7 Fedora Update System 2018-11-03 00:55:11 UTC
texlive-2018-21.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2478e665fd

Comment 8 Fedora Update System 2018-11-05 02:01:07 UTC
texlive-2018-21.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.