Bug 1643722 - wxmaxima (18.02.10) does not properly render text after scrooling the page
Summary: wxmaxima (18.02.10) does not properly render text after scrooling the page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxMaxima
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-27 22:09 UTC by Eduardo
Modified: 2019-05-13 08:57 UTC (History)
5 users (show)

Fixed In Version: wxMaxima-18.12.0-1.fc29 wxMaxima-19.05.0-1.fc30 wxMaxima-19.05.0-1.fc28 wxMaxima-19.05.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 02:35:59 UTC
Type: ---


Attachments (Terms of Use)

Description Eduardo 2018-10-27 22:09:17 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build Identifier: 

When using wxmaxima, just the first lines are correctly rendered. After srcooling the page (by entering many clines of commands), the rendering just gets crazy and it is impossible to select text using the mouse or even navigate using the keys. It used to work with F28. One important component may be my video card (NVIDIA with driver 410.66), altougth I cannot assure that. 


Reproducible: Always

Steps to Reproduce:
1. Run wxmaxima
2. Enter many lines of commands (in order to scrool the page). 
Actual Results:  
The rendering of text gets crazy and it is impossible to edit the text.

Expected Results:  
Normal rendering. Also, it would be possible to navigate using the mouse or the keys.

It seems to be something related to video driver or to gnome itself. I am using a very plain F29, without any modification.

Comment 1 James 2018-11-06 20:17:28 UTC
Seen here. Intel X3100 graphics, Gnome 3 under X11. maxima-5.41.0-8.fc29.x86_64

Comment 2 Eduardo 2018-11-16 13:31:27 UTC
I just compiled from the wxmaxima master branch and it is working. To be able to compile I installed wxGTK3-devel.

(Build from Git version: 925726bf)

wxWidgets: 3.0.4
Unicode support: yes
Maxima version: 5.42.1 (x86_64-redhat-linux-gnu)
Lisp: SBCL 1.4.6-2.fc29

Comment 3 Rex Dieter 2018-11-16 14:21:48 UTC
I cannot reproduce, and shipping a master snapshot isn't really an option either.

Someone experiencing this, mind submitting an issue upstream?

https://github.com/wxMaxima-developers/wxmaxima/issues

Comment 4 Nicola 2018-11-24 23:22:44 UTC
Add a me too. Same crazy behaviour. Moreover, after scrolling some output and going back to, say, a list of numbers, it's impossible to select a number. You aim at something and the selection goes to something else a couple of cm above!

Fedora 29 x64, fully upgraded as of today. Under X11, amdgpu, RX 560, Gnome shell, 4k resolution.

wxMaxima-18.10.0-1.fc29.x86_64

Comment 5 Nicola 2018-11-24 23:35:08 UTC
And yes, compiling wxmaxima from latest github provides a working interface.

Comment 6 Fedora Update System 2018-11-25 02:39:47 UTC
wxMaxima-18.10.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a19c1577f1

Comment 7 Rex Dieter 2018-11-25 02:40:38 UTC
A slightly newer build, let me know if that helps (I suspect not, but I'd love to be pleasantly surprised).

Comment 8 Fedora Update System 2018-11-26 02:46:02 UTC
wxMaxima-18.10.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a19c1577f1

Comment 9 José Matos 2018-11-26 21:36:44 UTC
I see the same issue.

Trying to open a wxmaxima file and looking into ~/.xsession-errors I see:
(/usr/lib64/firefox/firefox:12103): Gtk-WARNING **: 21:29:42.625: Theme directory actions32@2x of theme breeze-dark has no size field


(wxmaxima:5112): Gtk-WARNING **: 21:29:44.356: Theme directory actions32@2x of theme breeze-dark has no size field

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

The last part is repeated at least 8 times.

Comment 10 Fedora Update System 2018-11-26 21:44:56 UTC
wxMaxima-18.11.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a19c1577f1

Comment 11 Fedora Update System 2018-11-27 05:13:26 UTC
wxMaxima-18.11.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a19c1577f1

Comment 12 Fedora Update System 2018-12-05 02:34:44 UTC
wxMaxima-18.11.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-12-29 11:18:49 UTC
wxMaxima-18.12.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f1463d3af2

Comment 14 Fedora Update System 2018-12-30 03:17:19 UTC
wxMaxima-18.12.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f1463d3af2

Comment 15 Fedora Update System 2019-01-07 02:35:59 UTC
wxMaxima-18.12.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Ian Dall 2019-05-02 12:45:58 UTC
This problem still exists in 19.03.1-1.fc29. There seems to be a fix upstream in 19.04.3. See https://github.com/wxMaxima-developers/wxmaxima/pull/1049

Comment 17 Ian Dall 2019-05-02 12:49:55 UTC
Ans still exists in 19.04.1.

Comment 18 José Matos 2019-05-02 13:18:05 UTC
(In reply to Ian Dall from comment #16)
> This problem still exists in 19.03.1-1.fc29. There seems to be a fix
> upstream in 19.04.3. See
> https://github.com/wxMaxima-developers/wxmaxima/pull/1049

Could you try to see if https://bodhi.fedoraproject.org/updates/FEDORA-2019-b89703fda3
fixes it for you.

It has a similar fix.
It fixes the problem for me on Fedora 30.

I will update with the new package tomorrow.

Comment 19 José Matos 2019-05-02 13:31:22 UTC
(In reply to Ian Dall from comment #16)
> This problem still exists in 19.03.1-1.fc29. There seems to be a fix
> upstream in 19.04.3. See
> https://github.com/wxMaxima-developers/wxmaxima/pull/1049

This does not fix the issue. The upstream report is here
https://github.com/wxMaxima-developers/wxmaxima/issues/1113

Comment 20 Ian Dall 2019-05-02 15:36:40 UTC
This works: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b89703fda3

Comment 21 Fedora Update System 2019-05-02 16:20:09 UTC
wxMaxima-19.04.3-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b89703fda3

Comment 22 Fedora Update System 2019-05-04 10:24:07 UTC
wxMaxima-19.05.0-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-79cc104daf

Comment 23 Fedora Update System 2019-05-04 10:24:11 UTC
wxMaxima-19.05.0-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-79cc104daf

Comment 24 Fedora Update System 2019-05-04 10:25:25 UTC
wxMaxima-19.05.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b89703fda3

Comment 25 Fedora Update System 2019-05-04 10:27:22 UTC
wxMaxima-19.05.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-88bbb132f0

Comment 26 Fedora Update System 2019-05-04 10:27:26 UTC
wxMaxima-19.05.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-88bbb132f0

Comment 27 José Matos 2019-05-04 10:52:05 UTC
The above updates (19.05.0-1) fix the issue with the display of notebooks with more than one page: (https://github.com/wxMaxima-developers/wxmaxima/issues/1113).
The fix was already used at the 19.04.3-2 release from the upstream patch that went into 19.05.0.

This update also fixes another problem where the use of a dark theme had some redrawing problems (https://github.com/wxMaxima-developers/wxmaxima/issues/1110) this problem occurs for all the supported versions.

If all goes well this will be the last update to Fedora 28.

Comment 28 Fedora Update System 2019-05-05 00:53:30 UTC
wxMaxima-19.05.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-79cc104daf

Comment 29 Fedora Update System 2019-05-05 01:50:39 UTC
wxMaxima-19.05.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b89703fda3

Comment 30 Fedora Update System 2019-05-05 03:22:46 UTC
wxMaxima-19.05.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-88bbb132f0

Comment 31 Fedora Update System 2019-05-13 01:07:43 UTC
wxMaxima-19.05.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2019-05-13 02:12:04 UTC
wxMaxima-19.05.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2019-05-13 08:57:03 UTC
wxMaxima-19.05.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.