Bug 1643774 - "NVIDIA Linux Graphics Driver" and "Steam" cannot be found in GNOME Software
Summary: "NVIDIA Linux Graphics Driver" and "Steam" cannot be found in GNOME Software
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-workstation-repositories
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-10-28 15:28 UTC by Daniel Rusek
Modified: 2018-11-04 19:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-04 19:54:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Rusek 2018-10-28 15:28:17 UTC
Description of problem:
"NVIDIA Linux Graphics Driver" and "Steam" cannot be found in GNOME Software on Fedora 29 with the third-party repositories properly enabled. There is no such issue on Fedora 28. It looks like there is some issue with the rpmfusion-nonfree-nvidia-driver and rpmfusion-nonfree-steam repositories AppData.

Version-Release number of selected component (if applicable):
gnome-software-3.30.5-1.fc29.x86_64
fedora-workstation-repositories-29-1.fc29.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. Install and fully update Fedora 29 Workstation.
2. Run GNOME Software and enable the third-party repositories (see Additional info).
3. Try to find "Steam" or "NVIDIA Linux Graphics Driver" in GNOME Software.

Actual results:
"NVIDIA Linux Graphics Driver" and "Steam" cannot be found.

Expected results:
"NVIDIA Linux Graphics Driver" and "Steam" entries are properly displayed and are available for easy installation.

Additional info:
https://fedoramagazine.org/third-party-repositories-fedora/

Comment 1 Fedora Blocker Bugs Application 2018-10-28 15:56:35 UTC
Proposed as a Blocker for 29-final by Fedora user asciiwolf using the blocker tracking app because:

 I think this breaks the default application functionality rule because it prevents NVIDIA Drivers and Steam from being installed using the GNOME Software application. This is a major issue for end-users that are not experienced with command-line because there is no other way than using the Terminal to install NVIDIA Drivers or Steam on Fedora 29.

Comment 2 Andre Robatino 2018-10-28 19:02:24 UTC
Unfortunately, it's too late to change F29 since it already went Gold on the 25th and is due for official release on the 30th. This will have to be fixed with an update.

Comment 3 Daniel Rusek 2018-10-28 20:14:17 UTC
I have tried downgrading the appstream-data package, but that didn't help. So this is most likely a bug in GNOME Software. Both PyCharm and Chrome are showing without any issue, only the NVIDIA Drivers and Steam are not. I Hope this will get fixed soon because it is a big issue especially for users with NVIDIA who don't know how or don't want to use terminal to install the drivers.

Comment 4 Daniel Rusek 2018-10-28 21:14:20 UTC
By the way, I think that there should be some kind of automated test for this to prevent it from being broken again in the future.

Comment 5 Daniel Rusek 2018-10-29 12:04:34 UTC
I have tried downgrading the fedora-workstation-repositories (to 6 months old version) and gnome-software (to 3.28) packages and there is still the same issue.

Comment 6 Daniel Rusek 2018-10-29 12:18:40 UTC
I have tried various appstream-data and fedora-workstation-repositories package versions (both from f29 and f28) and still no luck. So it looks like the problem is probably somewhere else. I have also tried the older non-updated Fedora 29 Beta 1.5 and there was the same issue with NVIDIA Drivers and Steam not showing in GNOME Software after installing the fedora-workstation-repositories package.

Comment 7 Daniel Rusek 2018-10-29 13:20:06 UTC
I have also tried downgrading the PackageKit packages and still no luck. So maybe it is an issue on the RPM Fusion side.

Comment 8 Robbi Nespu 2018-10-30 01:21:52 UTC
Hi, I am new. My finding are repos are available but baseurl comment out on spec

I created PR on https://src.fedoraproject.org/rpms/fedora-workstation-repositories/pull-request/6

But I don't have the machine to test or not. Please check and review.

Comment 9 Daniel Rusek 2018-10-30 11:06:50 UTC
The baseurl is commented out on Fedora 28 as well. The metalink seems to be used instead.

Comment 10 Daniel Rusek 2018-10-30 12:22:26 UTC
I tested installing the packages using pkcon and they could be installed without any issue. The only thing that seems to be missing are the repo metadata:

$ ls /var/cache/app-info/xmls/
phracek-PyCharm.xml.gz
$ ls /var/cache/app-info/icons/
phracek-PyCharm

Comment 11 Daniel Rusek 2018-10-30 17:30:23 UTC
I have just tested this on a new, clean install of F29 Final and there's unfortunately still the same issue.

Comment 12 Daniel Rusek 2018-10-31 12:22:20 UTC
Hmm, I have tried replacing the $releasever variable with the previous "28" release (without quotes), but, unfortunately, nothing changed. :-( So I am now not sure if the issue is on the RPM Fusion side or not.

Comment 13 Daniel Rusek 2018-11-01 13:36:19 UTC
I switched the BZ to the fedora-workstation-repositories package because it doesn't seem to be a GS issue.

I also tried downgrading the librepo package, but still no luck. The last dependency that remains is libdnf, but it is not easy to downgrade this to a few months older version without breaking the whole system and I currently don't have enough time.

Comment 14 Daniel Rusek 2018-11-01 15:52:19 UTC
Hmm, I just tried this with a clean Fedora 28 system (first clean install, then after full update) and there's the same issue! However I remember that it was working fine few months ago.

Comment 15 Daniel Rusek 2018-11-01 16:12:30 UTC
I filed a RPM Fusion bz for this: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5067

Comment 16 Daniel Rusek 2018-11-04 19:54:05 UTC
This was really a RPM Fusion issue, not a Fedora one, and was fixed today.


Note You need to log in before you can comment on or make changes to this bug.