Bug 164386 - hal-cups-utils package depends on system-config-printer
hal-cups-utils package depends on system-config-printer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 11:46 EDT by Lamont Peterson
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 12:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lamont Peterson 2005-07-27 11:46:13 EDT
Description of problem: 
I have to have system-config-printer installed if I want cups installed, 
because this package (hal-cups-utils) depends on system-config-printer. 
 
Is this not backwards? 
 
Taking a quick, cursory look at what is in hal-cups-utils, I do not see 
anything that would warrant such a dependency.  Of course, as I didn't look 
deep there could easily be a good technical reason, but that seems doubtful. 
 
Using --nodeps to remove system-config-printer does not seem to have affected 
hal-cups-utils negatively. 
 
Version-Release number of selected component (if applicable): 
hal-cups-utils-0.5.3-3 
system-config-printer-0.6.131.3-1 
   
Actual results: 
Trying to remove system-config-printer (and keep hal-cups-utils) fails because 
of dependencies). 
 
Expected results: 
One should be able to remove a package like system-config-printer and still 
keep the lower level functions/tools.
Comment 1 John (J5) Palmieri 2005-07-27 12:09:26 EDT
You don't need to have hal-cups-utils to have cups installed.  hal-cups-utils
needs system-config-printer to autoconfigure printers.  hal-cups-utils is just
the bridge between cups, hal and printconf (which is provided by
system-config-printer).  hal-cups-utils is pretty useless without it.

Note You need to log in before you can comment on or make changes to this bug.