Bug 1643864 - ibus-gtk3 should not require ibus
Summary: ibus-gtk3 should not require ibus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1646848
TreeView+ depends on / blocked
 
Reported: 2018-10-29 09:19 UTC by fujiwara
Modified: 2018-11-27 17:11 UTC (History)
3 users (show)

Fixed In Version: ibus-1.5.19-7.fc29 ibus-1.5.19-8.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1646848 (view as bug list)
Environment:
Last Closed: 2018-11-04 06:51:11 UTC


Attachments (Terms of Use)

Description fujiwara 2018-10-29 09:19:27 UTC
ibus-gtk[2|3] have depended ibus not to break the API compatibility between ibus and ibus-libs since some applications could require ibus-libs only without ibus.
Actually ibus-libs does not require ibus but needs to keep the same version between ibus and ibus-libs.

Now I think 'Conflicts:' tag is the right usage for the purpose and will delete 'Requires: ibus' in ibus-gtk* and use 'Conflicts: ibus < version' in ibus-libs.

Comment 1 Fedora Update System 2018-10-29 09:36:24 UTC
ibus-1.5.19-6.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f24d1ee9d

Comment 2 Fedora Update System 2018-10-29 11:31:42 UTC
ibus-1.5.19-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-998a7b6fc3

Comment 3 Fedora Update System 2018-10-31 11:20:03 UTC
ibus-1.5.19-7.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f24d1ee9d

Comment 4 Fedora Update System 2018-10-31 11:21:55 UTC
ibus-1.5.19-7.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-998a7b6fc3

Comment 5 Fedora Update System 2018-10-31 17:30:25 UTC
ibus-1.5.19-7.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-998a7b6fc3

Comment 6 Fedora Update System 2018-10-31 18:50:52 UTC
ibus-1.5.19-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f24d1ee9d

Comment 7 Fedora Update System 2018-11-04 06:51:11 UTC
ibus-1.5.19-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-11-06 12:56:02 UTC
ibus-1.5.19-8.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-998a7b6fc3

Comment 9 Fedora Update System 2018-11-07 04:24:13 UTC
ibus-1.5.19-8.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-998a7b6fc3

Comment 10 Fedora Update System 2018-11-27 02:27:01 UTC
ibus-1.5.19-8.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-11-27 17:11:38 UTC
ibus-1.5.19-8.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.