Bug 1643935 - cliutils: geo-rep cliutils' usage of Popen is not python3 compatible
Summary: cliutils: geo-rep cliutils' usage of Popen is not python3 compatible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1644161
TreeView+ depends on / blocked
 
Reported: 2018-10-29 13:27 UTC by Kotresh HR
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1644161 (view as bug list)
Environment:
Last Closed: 2018-11-28 04:47:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21506 0 None Merged cliutils: python2 to python3 compat 2018-10-30 05:56:07 UTC

Description Kotresh HR 2018-10-29 13:27:21 UTC
Description of problem:
geo-rep cliutils' usage of Popen is not python3 compatible

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:


Actual results:
Sometimes geo-rep cliutils crashes

Expected results:
geo-rep cliutils should not crash.

Additional info:

Comment 1 Worker Ant 2018-10-29 13:29:30 UTC
REVIEW: https://review.gluster.org/21506 (cliutils: python2 to python3 compat) posted (#2) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-10-30 05:56:06 UTC
REVIEW: https://review.gluster.org/21506 (cliutils: python2 to python3 compat) posted (#3) for review on master by Amar Tumballi

Comment 3 Kotresh HR 2018-11-28 04:47:38 UTC
Fixed in v5.1

Comment 4 Shyamsundar 2019-03-25 16:31:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.