Bug 1644013 - Touchscreen function for HP laptop with AMD processors broken on all kernel version
Summary: Touchscreen function for HP laptop with AMD processors broken on all kernel v...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://www.google.com/search?client=...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-29 18:25 UTC by Luya Tshimbalanga
Modified: 2019-04-05 08:06 UTC (History)
18 users (show)

Fixed In Version: kernel-4.19.3-300.fc29 kernel-4.19.3-200.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-11-24 02:28:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot report with kernel-4.19.0 on fresh installation (244.63 KB, text/plain)
2018-10-29 18:25 UTC, Luya Tshimbalanga
no flags Details
attempt to fix acpi table (1.50 KB, patch)
2018-11-08 10:39 UTC, Luya Tshimbalanga
no flags Details | Diff
boot report with kernel-4.19.2 (629.34 KB, text/plain)
2018-11-17 17:19 UTC, Luya Tshimbalanga
no flags Details
boot report with kernel-4.19.2 scratch build (78.36 KB, text/plain)
2018-11-20 16:01 UTC, Luya Tshimbalanga
no flags Details
Journal report (253.24 KB, text/x-vhdl)
2018-11-20 16:21 UTC, Luya Tshimbalanga
no flags Details
acpidump data (870.34 KB, text/plain)
2018-11-20 23:16 UTC, Luya Tshimbalanga
no flags Details
Journal report with irqpool parameter (243.31 KB, text/x-vhdl)
2018-11-20 23:35 UTC, Luya Tshimbalanga
no flags Details
dmesg boot report with irqpoll (81.87 KB, text/plain)
2018-11-20 23:41 UTC, Luya Tshimbalanga
no flags Details
acpidump data after bios update (870.34 KB, text/plain)
2018-11-21 05:35 UTC, Luya Tshimbalanga
no flags Details
dmesg boot report with irqpoll after update (78.12 KB, text/plain)
2018-11-21 05:43 UTC, Luya Tshimbalanga
no flags Details
Journal report with irqpool parameter after bios update (266.31 KB, text/plain)
2018-11-21 05:46 UTC, Luya Tshimbalanga
no flags Details
acpidump data after bios update (870.34 KB, text/plain)
2018-11-21 05:51 UTC, Luya Tshimbalanga
no flags Details
Journal report after bios update (242.68 KB, text/plain)
2018-11-21 06:02 UTC, Luya Tshimbalanga
no flags Details
dmesg with i2c info (78.81 KB, text/plain)
2018-11-21 16:19 UTC, Luya Tshimbalanga
no flags Details
dmesg with i2c info (78.81 KB, text/plain)
2018-11-21 16:20 UTC, Luya Tshimbalanga
no flags Details
cat /proc/interrupts (6.93 KB, text/plain)
2018-11-21 23:54 UTC, Luya Tshimbalanga
no flags Details
Journal report with noirqdebug parameter (1.19 MB, text/plain)
2018-11-22 01:13 UTC, Luya Tshimbalanga
no flags Details
dmesg with rolledback bios (75.47 KB, text/plain)
2018-11-22 16:55 UTC, Luya Tshimbalanga
no flags Details
Journal boot with rollback bios (255.87 KB, text/plain)
2018-11-22 16:58 UTC, Luya Tshimbalanga
no flags Details
Journal boot with rollback bios default paramaters (219.84 KB, text/plain)
2018-11-22 16:59 UTC, Luya Tshimbalanga
no flags Details
updated dmesg (77.79 KB, text/plain)
2018-11-23 00:11 UTC, Luya Tshimbalanga
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 198715 None None None 2019-04-05 07:39 UTC

Description Luya Tshimbalanga 2018-10-29 18:25:06 UTC
Created attachment 1498621 [details]
boot report with kernel-4.19.0 on fresh installation

Description of problem:
The support of touchscreen and by extend stylus is currently broken on the latest kernel release. Looking at the journal boot shows error related to ACPI. Test done on HP Envy x360 Ryzen and attached upstream report included.

Version-Release number of selected component (if applicable):
4.19.0 

How reproducible:
Always

Steps to Reproduce:
1. Fresh installation 
2.
3.

Actual results:
Touchscreen failed

Expected results:
Touchscreen works as intended

Additional info:
Oct 27 23:02:45 kernel: acer_wmi: Acer Laptop ACPI-WMI Extras
Oct 27 23:02:45 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: input: HP WMI hotkeys as /devices/virtual/input/input11
Oct 27 23:02:45 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Oct 27 23:02:45 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)

Comment 1 Luya Tshimbalanga 2018-11-01 09:16:26 UTC
The report revealed a misconfiguration inside acpi table as the cause of failure for touchscreen and active pen. See link below:
https://bugzilla.kernel.org/attachment.cgi?id=275599&action=edit

It will be nice someone from kernel team to provide a patch for testing. Upstream seems very busy considering the delay of response and the fact the issue exists on all HP Envy model equipped with AMD chipsets since at least FX 9800P.

Comment 2 Luya Tshimbalanga 2018-11-08 10:39 UTC
Created attachment 1503297 [details]
attempt to fix acpi table

Provided patch from one of user attempting to restore touchscreen functionality. It will be nice if one of kernel maintainers improve it.

Comment 3 Luya Tshimbalanga 2018-11-17 16:56:12 UTC
Further clarify the bug affecting all AMD powered HP touchscreen laptops.

Comment 4 Luya Tshimbalanga 2018-11-17 17:19 UTC
Created attachment 1506804 [details]
boot report with kernel-4.19.2

Updated journalctl -b -1 --no-hostname

Comment 5 Hans de Goede 2018-11-19 11:42:39 UTC
Hi Luya,

Thank you for filing a bug for this and for pointing to the work done by Lukas in https://bugzilla.kernel.org/show_bug.cgi?id=199523

I don't see any really obvious nice answer here.

So I believe it is best to override the IRQ type manually in the AMD gpio driver to correct the acpi_get_override_irq() results from the ACPI core.

I've written a patch doing this and attached it to:
https://bugzilla.kernel.org/show_bug.cgi?id=199523

Once I get confirmation that this fixes things I will submit the patch upstream. 

And once accepted upstream it can be added to the Fedora kernels.

Regards,

Hans

Comment 6 Luya Tshimbalanga 2018-11-20 05:31:05 UTC
Hi Hans,

I followed the upstream report and thank you and the testers for working on the issue. Looking to try the fix soon.

Luya

Comment 7 Hans de Goede 2018-11-20 11:04:16 UTC
I've started a scratch-build of a kernel with the second patch from
https://bugzilla.kernel.org/show_bug.cgi?id=198715 added to it.

You can find this scratch-build here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=31015962

Once this is done building (this takes a couple of hours) please follow these instructions to install and test the kernel and let us know if this fixes things:
https://fedorapeople.org/~jwrdegoede/kernel-test-instructions.txt

Note that since this is a scratch-build it is not signed, so you need to disable secure-boot if you have it enabled.

Comment 8 Hans de Goede 2018-11-20 14:55:08 UTC
Note the kernel scratch-build is finished now, so if you can give it a try that would be great.

Comment 9 Luya Tshimbalanga 2018-11-20 16:01 UTC
Created attachment 1507426 [details]
boot report with kernel-4.19.2 scratch build

Unfortunately, the patched kernel still failed to restore touchscreen function.

cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.19.2-301.hdg1.fc29.x86_64 root=UUID=607ff45d-a687-4c63-8fa3-359b27cee7bd ro resume=UUID=3d768890-e655-4465-90fd-8bf8c9e1209b rhgb quiet LANG=en_CA.UTF-8

Secure Boot is disabled and legacy mode is disabled.

Comment 10 Luya Tshimbalanga 2018-11-20 16:21 UTC
Created attachment 1507440 [details]
Journal report

Added journal report with error lines:

Nov 20 08:04:34 kernel: Hardware name: HP HP ENVY x360 Convertible 15-cp0xxx/8497, BIOS F.20 09/26/2018
Nov 20 08:04:34 kernel: Call Trace:
Nov 20 08:04:34 kernel:  <IRQ>
Nov 20 08:04:34 kernel:  dump_stack+0x5c/0x80
Nov 20 08:04:34 kernel:  __report_bad_irq+0x37/0xae
Nov 20 08:04:34 kernel:  note_interrupt.cold.9+0xa/0x69
Nov 20 08:04:34 kernel:  handle_irq_event_percpu+0x6a/0x80
Nov 20 08:04:34 kernel:  handle_irq_event+0x27/0x44
Nov 20 08:04:34 kernel:  handle_fasteoi_irq+0x7f/0x120
Nov 20 08:04:34 kernel:  handle_irq+0xbf/0x100
Nov 20 08:04:34 kernel:  do_IRQ+0x49/0xd0
Nov 20 08:04:34 kernel:  common_interrupt+0xf/0xf
Nov 20 08:04:34 kernel:  </IRQ>
...

Nov 20 08:04:34 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: input: HP WMI hotkeys as /devices/virtual/input/input25
Nov 20 08:04:34 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180810/dsopcode-201)
Nov 20 08:04:34 kernel: ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Nov 20 08:04:34 kernel: ACPI Error: Method

Comment 11 Hans de Goede 2018-11-20 16:36:30 UTC
OK, so your new journal/dmesg log shows that:

1) The "kernel: ACPI: IRQ 7 override to edge, high" message is gone (good)
2) The following messages are new, indicating that the touchscreen is now being detected:

Nov 20 00:04:31 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vdd not found, using dummy regulator
Nov 20 00:04:31 kernel: i2c_hid i2c-ELAN0732:00: Linked as a consumer to regulator.0
Nov 20 00:04:31 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vddl not found, using dummy regulator
Nov 20 00:04:31 kernel: input: ELAN0732:00 04F3:264C Touchscreen as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input6
Nov 20 00:04:31 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input7
Nov 20 00:04:31 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input8
Nov 20 00:04:31 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input9
Nov 20 00:04:31 kernel: hid-generic 0018:04F3:264C.0001: input,hidraw0: I2C HID v1.00 Device [ELAN0732:00 04F3:264C] on i2c-ELAN0732:00

But it shows a new problem, not seen by the other reporters in the kernel bugzilla:

Nov 20 08:04:34 kernel: irq 7: nobody cared (try booting with the "irqpoll" option)
Nov 20 08:04:34 kernel: CPU: 5 PID: 0 Comm: swapper/5 Tainted: G         C        4.19.2-301.hdg1.fc29.x86_64 #1
Nov 20 08:04:34 kernel: Hardware name: HP HP ENVY x360 Convertible 15-cp0xxx/8497, BIOS F.20 09/26/2018
Nov 20 08:04:34 kernel: Call Trace:
Nov 20 08:04:34 kernel:  <IRQ>
Nov 20 08:04:34 kernel:  dump_stack+0x5c/0x80
Nov 20 08:04:34 kernel:  __report_bad_irq+0x37/0xae
Nov 20 08:04:34 kernel:  note_interrupt.cold.9+0xa/0x69
Nov 20 08:04:34 kernel:  handle_irq_event_percpu+0x6a/0x80
Nov 20 08:04:34 kernel:  handle_irq_event+0x27/0x44
Nov 20 08:04:34 kernel:  handle_fasteoi_irq+0x7f/0x120
Nov 20 08:04:34 kernel:  handle_irq+0xbf/0x100
Nov 20 08:04:34 kernel:  do_IRQ+0x49/0xd0
Nov 20 08:04:34 kernel:  common_interrupt+0xf/0xf
Nov 20 08:04:34 kernel:  </IRQ>
Nov 20 08:04:34 kernel: RIP: 0010:cpuidle_enter_state+0xb9/0x320
Nov 20 08:04:34 kernel: Code: e8 0c 81 97 ff 80 7c 24 0b 00 74 17 9c 58 0f 1f 44 00 00 f6 c4 02 0f 85 3b 02 00 00 31 ff e8 4e 3a 9d ff fb 66 0f 1f 44 00 00 <48> b8 ff ff ff ff f3 01 00 00 48 2b 1c 24 ba ff ff ff 7f 48 39 c3
Nov 20 08:04:34 kernel: RSP: 0018:ffff97b3419ebe90 EFLAGS: 00000246 ORIG_RAX: ffffffffffffffdb
Nov 20 08:04:34 kernel: RAX: ffff89818fb60f80 RBX: 000000012f8950e9 RCX: 000000000000001f
Nov 20 08:04:34 kernel: RDX: 000000012f8950e9 RSI: 000000004010c72a RDI: 0000000000000000
Nov 20 08:04:34 kernel: RBP: ffff898187ab1c00 R08: 0000000000000002 R09: 0000000000020800
Nov 20 08:04:34 kernel: R10: 00000006e8c93b70 R11: ffff89818fb5fde8 R12: 0000000000000001
Nov 20 08:04:34 kernel: R13: ffffffff9f2dd2d8 R14: 0000000000000001 R15: 0000000000000000
Nov 20 08:04:34 kernel:  do_idle+0x226/0x260
Nov 20 08:04:34 kernel:  cpu_startup_entry+0x6f/0x80
Nov 20 08:04:34 kernel:  start_secondary+0x1a7/0x200
Nov 20 08:04:34 kernel:  secondary_startup_64+0xa4/0xb0
Nov 20 08:04:34 kernel: handlers:
Nov 20 08:04:34 kernel: [<0000000008b05883>] amd_gpio_irq_handler [pinctrl_amd]
Nov 20 08:04:34 kernel: Disabling IRQ #7

Which seems to indicate that the amd_gpio pinctrl driver seems to not properly quiesce unused interrupts; or some other device is also on irq 7 and we don't have a driver for that other device.

Can you try booting with the "irqpoll" option.

also please run:

acpidump -o acidump.txt

And attach the generated acpidump.txt file here.

Comment 12 Luya Tshimbalanga 2018-11-20 23:16 UTC
Created attachment 1507472 [details]
acpidump data

Here is the requested acpidump data. The touchscreen worked but the entire system somehow locked up after login. I will post either dmesg or journalctl report in a few moment.

Comment 13 Luya Tshimbalanga 2018-11-20 23:35 UTC
Created attachment 1507474 [details]
Journal report with irqpool parameter

Journal report

Comment 14 Luya Tshimbalanga 2018-11-20 23:41 UTC
Created attachment 1507475 [details]
dmesg boot report with irqpoll

Using irqpool as parameter enabled touchscreen. Unfortunately, the entire session after login froze forcing to do hard reset possibly suggesting a conflict with amdgio. I had to go in console mode to retrieve requested data otherwise lockup occurs.

Comment 15 Luya Tshimbalanga 2018-11-21 05:35 UTC
Created attachment 1507548 [details]
acpidump data after bios update

acpidump data after latest bios update

Comment 16 Luya Tshimbalanga 2018-11-21 05:43 UTC
Created attachment 1507549 [details]
dmesg boot report with irqpoll after update

Installed the recent BIOS update from HP (https://support.hp.com/ca-en/drivers/selfservice/swdetails/hp-envy-15-cp0000-x360-convertible-pc/20270303/swItemId/ob-220883-1) which seems impacting the i2c_hid probe

[    3.478478] i2c_hid i2c-ELAN0732:00: HID over i2c has not been provided an Int IRQ
[    3.478525] i2c_hid: probe of i2c-ELAN0732:00 failed with error -22

Comment 17 Luya Tshimbalanga 2018-11-21 05:46 UTC
Created attachment 1507550 [details]
Journal report with irqpool parameter after bios update

Additional journal report

Comment 18 Luya Tshimbalanga 2018-11-21 05:51 UTC
Created attachment 1507551 [details]
acpidump data after bios update

acpidump data without irqpool parameter on boot

Comment 19 Luya Tshimbalanga 2018-11-21 06:02 UTC
Created attachment 1507554 [details]
Journal report after bios update

 It turned out a BIOS update from HP (https://support.hp.com/ca-en/drivers/selfservice/swdetails/hp-envy-15-cp0000-x360-convertible-pc/20270303/swItemId/ob-220883-1)fixed the irq issue after removing the irqpoll parameter and I no longer notice a lockup on desktop session.

The stylus coming with HP Envy x360 Ryzen 2500U now works for the first time.
Should you need an additional dmesg, let me know.

Thank you Hans for taking this issue. You are really awesome!

Comment 20 Luya Tshimbalanga 2018-11-21 06:49:51 UTC
It looks like the touchscreen is missing vdd as seen on

Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vdd not found, using dummy regulator
Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: Linked as a consumer to regulator.0
Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vddl not found, using dummy regulator
Nov 20 13

Comment 21 Hans de Goede 2018-11-21 08:58:29 UTC
(In reply to Luya Tshimbalanga from comment #20)
> It looks like the touchscreen is missing vdd as seen on
> 
> Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vdd
> not found, using dummy regulator
> Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: Linked as a consumer to
> regulator.0
> Nov 20 13:46:44 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vddl
> not found, using dummy regulator
> Nov 20 13

These messages are harmless, the vdd[l] regulator support is only used on ARM devices, so these messages can be safely ignored.

(In reply to Luya Tshimbalanga from comment #19)
> It turned out a BIOS update from HP fixed the irq issue
> after removing the irqpoll parameter and I no longer notice a lockup on
> desktop session.
> 
> The stylus coming with HP Envy x360 Ryzen 2500U now works for the first time.
> Should you need an additional dmesg, let me know.

Ok, so I believe that this bug can be closed then once the kernel with the fix hits updates-stable, right ?

Comment 22 Hans de Goede 2018-11-21 08:59:22 UTC
p.s.

I compared the apcidumps before and after the BIOS update and no changes were made to the DSDT, but I guess they fixes some part of the AMD GPIO chip initialization.

Comment 23 Hans de Goede 2018-11-21 09:45:59 UTC
BTW, I noticed the following message in your dmesg:

kernel: psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.

Can you try booting with psmouse.synaptics_intertouch=1 added to your kernel commandline and then run "dmesg > dmesg.txt" and attach dmesg.txt here ?

If your touchpad supports the RMI bus then that will lead to a better touchpad experience (sending coordinates for up-to 5 fingers when doing multi-touch instead of for just 2 fingers).

Comment 24 Luya Tshimbalanga 2018-11-21 16:19 UTC
Created attachment 1507733 [details]
dmesg with i2c info

Here is.

Comment 25 Luya Tshimbalanga 2018-11-21 16:20 UTC
Created attachment 1507734 [details]
dmesg with i2c info

Here is

Comment 26 Luya Tshimbalanga 2018-11-21 16:33:22 UTC
The dmesg file mentions
i2c_hid i2c-ELAN0732:00: i2c_hid_get_input: incomplete report (67/65535)

After reboot, I sometime hit "disable irq#7" message below:

[    5.739281] irq 7: nobody cared (try booting with the "irqpoll" option)
[    5.739284] CPU: 5 PID: 0 Comm: swapper/5 Tainted: G         C        4.19.2-301.hdg1.fc29.x86_64 #1
[    5.739285] Hardware name: HP HP ENVY x360 Convertible 15-cp0xxx/8497, BIOS F.21 10/19/2018
[    5.739285] Call Trace:
[    5.739288]  <IRQ>
[    5.739294]  dump_stack+0x5c/0x80
[    5.739297]  __report_bad_irq+0x37/0xae
[    5.739298]  note_interrupt.cold.9+0xa/0x69
[    5.739300]  handle_irq_event_percpu+0x6a/0x80
[    5.739301]  handle_irq_event+0x27/0x44
[    5.739302]  handle_fasteoi_irq+0x7f/0x120
[    5.739305]  handle_irq+0xbf/0x100
[    5.739307]  do_IRQ+0x49/0xd0
[    5.739308]  common_interrupt+0xf/0xf
[    5.739309]  </IRQ>
[    5.739312] RIP: 0010:cpuidle_enter_state+0xb9/0x320
[    5.739313] Code: e8 0c 81 97 ff 80 7c 24 0b 00 74 17 9c 58 0f 1f 44 00 00 f6 c4 02 0f 85 3b 02 00 00 31 ff e8 4e 3a 9d ff fb 66 0f 1f 44 00 00 <48> b8 ff ff ff ff f3 01 00 00 48 2b 1c 24 ba ff ff ff 7f 48 39 c3
[    5.739314] RSP: 0018:ffffbaea419ebe90 EFLAGS: 00000246 ORIG_RAX: ffffffffffffffdb
[    5.739315] RAX: ffff92ab8fd60f80 RBX: 00000001561655af RCX: 000000000000001f
[    5.739316] RDX: 00000001561655af RSI: 00000000401ec933 RDI: 0000000000000000
[    5.739317] RBP: ffff92ab8d77b000 R08: 0000000000000002 R09: 0000000000020800
[    5.739317] R10: 0000000c2cb8c5a8 R11: ffff92ab8fd5fde8 R12: 0000000000000001
[    5.739318] R13: ffffffffa02dd2d8 R14: 0000000000000001 R15: 0000000000000000
[    5.739322]  do_idle+0x226/0x260
[    5.739323]  cpu_startup_entry+0x6f/0x80
[    5.739325]  start_secondary+0x1a7/0x200
[    5.739328]  secondary_startup_64+0xa4/0xb0
[    5.739329] handlers:
[    5.739332] [<00000000f873226a>] amd_gpio_irq_handler [pinctrl_amd]
[    5.739333] Disabling IRQ #7

 irqpoll kinda fixed but the session grinds to halt somehow after log in.

Comment 27 Hans de Goede 2018-11-21 16:57:30 UTC
Ok, so the "psmouse.synaptics_intertouch=1" option does not seem to enable RMI access to the touchpad in your case, so you can remove that option.

As for the IRQ7 problem being back, that is a bummer.

Can you run:

lspci -v

And see if any device is listed as using IRQ 7 ?

Comment 28 Luya Tshimbalanga 2018-11-21 17:07:18 UTC
sudo lspci -v

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15d0
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: fast devsel

00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 15d1
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Capabilities: [40] Secure device <?>
	Capabilities: [64] MSI: Enable+ Count=1/4 Maskable- 64bit+
	Capabilities: [74] HyperTransport: MSI Mapping Enable+ Fixed+

00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
	Flags: fast devsel

00:01.6 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 26
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00001000-00001fff [size=4K]
	Memory behind bridge: fd000000-fd0fffff [size=1M]
	Prefetchable memory behind bridge: 00000000f0200000-00000000f03fffff [size=2M]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Root Port (Slot+), MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [c0] Subsystem: Hewlett-Packard Company Device 8497
	Capabilities: [c8] HyperTransport: MSI Mapping Enable+ Fixed+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Capabilities: [270] Secondary PCI Express <?>
	Capabilities: [2a0] Access Control Services
	Capabilities: [370] L1 PM Substates
	Kernel driver in use: pcieport

00:01.7 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3 (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	I/O behind bridge: 0000f000-0000ffff [size=4K]
	Memory behind bridge: fcf00000-fcffffff [size=1M]
	Prefetchable memory behind bridge: None
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Root Port (Slot+), MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [c0] Subsystem: Hewlett-Packard Company Device 8497
	Capabilities: [c8] HyperTransport: MSI Mapping Enable+ Fixed+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Capabilities: [270] Secondary PCI Express <?>
	Capabilities: [2a0] Access Control Services
	Capabilities: [370] L1 PM Substates
	Kernel driver in use: pcieport

00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
	Flags: fast devsel

00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15db (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 28
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	I/O behind bridge: 0000e000-0000efff [size=4K]
	Memory behind bridge: fc900000-fcdfffff [size=5M]
	Prefetchable memory behind bridge: 00000000e0000000-00000000f01fffff [size=258M]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Root Port (Slot-), MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [c0] Subsystem: Advanced Micro Devices, Inc. [AMD] Device 0000
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [270] Secondary PCI Express <?>
	Capabilities: [2a0] Access Control Services
	Kernel driver in use: pcieport

00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15dc (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 29
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
	I/O behind bridge: None
	Memory behind bridge: fce00000-fcefffff [size=1M]
	Prefetchable memory behind bridge: None
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Root Port (Slot-), MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [c0] Subsystem: Advanced Micro Devices, Inc. [AMD] Device 0000
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [270] Secondary PCI Express <?>
	Kernel driver in use: pcieport

00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: 66MHz, medium devsel
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c_piix4, sp5100_tco

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, 66MHz, medium devsel, latency 0

00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e8
	Flags: fast devsel

00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e9
	Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ea
	Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15eb
	Flags: fast devsel
	Kernel driver in use: k10temp
	Kernel modules: k10temp

00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ec
	Flags: fast devsel

00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ed
	Flags: fast devsel

00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ee
	Flags: fast devsel

00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ef
	Flags: fast devsel

01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
	DeviceName: Realtek PCIE CardReader
	Subsystem: Hewlett-Packard Company Device 8497
	Physical Slot: 0
	Flags: bus master, fast devsel, latency 0, IRQ 53
	Memory at fd000000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-00-00-01-00-4c-e0-00
	Capabilities: [150] Latency Tolerance Reporting
	Capabilities: [158] L1 PM Substates
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter
	DeviceName: Realtek RTL8822BE 802.11 ac 2x2 WiFi + BT 4.2 Combo Adapter (MU-MIMO supported)
	Subsystem: Hewlett-Packard Company Device 831b
	Flags: bus master, fast devsel, latency 0, IRQ 59
	I/O ports at f000 [size=256]
	Memory at fcf00000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [148] Device Serial Number 00-e0-4c-ff-fe-b8-22-01
	Capabilities: [158] Latency Tolerance Reporting
	Capabilities: [160] L1 PM Substates
	Kernel driver in use: r8822be
	Kernel modules: r8822be

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c4) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 54
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f0000000 (64-bit, prefetchable) [size=2M]
	I/O ports at e000 [size=256]
	Memory at fcd00000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/4 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable- Count=3 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [200] Resizable BAR <?>
	Capabilities: [270] Secondary PCI Express <?>
	Capabilities: [2a0] Access Control Services
	Capabilities: [2b0] Address Translation Service (ATS)
	Capabilities: [2c0] Page Request Interface (PRI)
	Capabilities: [2d0] Process Address Space ID (PASID)
	Capabilities: [320] Latency Tolerance Reporting
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15de
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 56
	Memory at fcd88000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 15df
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: fast devsel, IRQ 255
	Memory at fcc00000 (32-bit, non-prefetchable) [disabled] [size=1M]
	Memory at fcd8e000 (32-bit, non-prefetchable) [disabled] [size=8K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/2 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable- Count=2 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>

03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e0 (prog-if 30 [XHCI])
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 33
	Memory at fcb00000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/8 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable+ Count=8 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: xhci_hcd

03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e1 (prog-if 30 [XHCI])
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 42
	Memory at fca00000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/8 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable+ Count=8 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: xhci_hcd

03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Device 15e3
	DeviceName: HD Audio Controller
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 57
	Memory at fcd80000 (32-bit, non-prefetchable) [size=32K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

03:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Device 15e4
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: fast devsel, IRQ 255
	Memory at fc900000 (32-bit, non-prefetchable) [disabled] [size=1M]
	Memory at fcd8c000 (32-bit, non-prefetchable) [disabled] [size=8K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/2 Maskable- 64bit+
	Capabilities: [c0] MSI-X: Enable- Count=2 Masked-
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>

04:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61) (prog-if 01 [AHCI 1.0])
	Subsystem: Hewlett-Packard Company Device 8497
	Flags: bus master, fast devsel, latency 0, IRQ 31
	Memory at fce00000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=2/2 Maskable- 64bit+
	Capabilities: [d0] SATA HBA v1.0
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [270] Secondary PCI Express <?>
	Kernel driver in use: ahci


Apparently due to disable IRQ7. I'll get back after work.

Comment 29 Fedora Update System 2018-11-21 20:41:38 UTC
kernel-tools-4.19.3-300.fc29 kernel-4.19.3-300.fc29 kernel-headers-4.19.3-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-367d08ef69

Comment 30 Fedora Update System 2018-11-21 20:44:31 UTC
kernel-headers-4.19.3-200.fc28 kernel-tools-4.19.3-200.fc28 kernel-4.19.3-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cf713da0d

Comment 31 Luya Tshimbalanga 2018-11-21 23:54 UTC
Created attachment 1507860 [details]
cat /proc/interrupts

Using cat /proc/interrupts on the test kernel update shows:

 7:          0          0          0          0          0     100000          0          0  IR-IO-APIC    7-fasteoi   pinctrl_amd

pinctrl_amd seems causing the issue.

Comment 32 Luya Tshimbalanga 2018-11-22 01:12:32 UTC
It looks like adding noirqdebug on boot parameter resolve the issue. No sure if there is a better way.

Comment 33 Luya Tshimbalanga 2018-11-22 01:13 UTC
Created attachment 1507867 [details]
Journal report with noirqdebug parameter

Comment 34 Fedora Update System 2018-11-22 04:30:24 UTC
kernel-4.19.3-200.fc28, kernel-headers-4.19.3-200.fc28, kernel-tools-4.19.3-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cf713da0d

Comment 35 Fedora Update System 2018-11-22 05:38:51 UTC
kernel-4.19.3-300.fc29, kernel-headers-4.19.3-300.fc29, kernel-tools-4.19.3-300.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-367d08ef69

Comment 36 Hans de Goede 2018-11-22 07:55:30 UTC
What is the output of "cat /proc/interrupts | grep pinctrl_amd" after using the noirqdebug option ?

Also lets wait a bit to see of the problem does not come back all of a sudden as it did the last time.

Once we are sure that the noirqdebug option fixes things, we need to contact the upstream kerneldevs about this and figure out why this helps.

Comment 37 Luya Tshimbalanga 2018-11-22 09:15:14 UTC
(In reply to Hans de Goede from comment #36)
> What is the output of "cat /proc/interrupts | grep pinctrl_amd" after using
> the noirqdebug option ?

cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.19.3-300.fc29.x86_64 root=UUID=607ff45d-a687-4c63-8fa3-359b27cee7bd ro resume=UUID=3d768890-e655-4465-90fd-8bf8c9e1209b rhgb quiet LANG=en_CA.UTF-8 noirqdebug

cat /proc/interrupts | grep pinctrl_amd
   7:   23297947          0          0          0          0  870773174          0          0  IR-IO-APIC    7-fasteoi   pinctrl_amd

> Also lets wait a bit to see of the problem does not come back all of a
> sudden as it did the last time.

> Once we are sure that the noirqdebug option fixes things, we need to contact
> the upstream kerneldevs about this and figure out why this helps.

Ok. I am strill puzzled about those weird issue notaly using irqpoll parameter leading to a halt.

Comment 38 Hans de Goede 2018-11-22 09:42:58 UTC
(In reply to Luya Tshimbalanga from comment #37)
> (In reply to Hans de Goede from comment #36)
> > What is the output of "cat /proc/interrupts | grep pinctrl_amd" after using
> > the noirqdebug option ?
> 
> cat /proc/cmdline 
> BOOT_IMAGE=/vmlinuz-4.19.3-300.fc29.x86_64
> root=UUID=607ff45d-a687-4c63-8fa3-359b27cee7bd ro
> resume=UUID=3d768890-e655-4465-90fd-8bf8c9e1209b rhgb quiet LANG=en_CA.UTF-8
> noirqdebug
> 
> cat /proc/interrupts | grep pinctrl_amd
>    7:   23297947          0          0          0          0  870773174     
> 0          0  IR-IO-APIC    7-fasteoi   pinctrl_amd

Yeah, so this high numbers indicate that the problem is not fixed by noirqdebug at all, the kernel now just ignores that the IRQ is continuously firing and you will likely see a high CPU load in "top".

I've send a mail to people who have recently worked on the amd-pinctrl driver asking for help with this.

Comment 39 Luya Tshimbalanga 2018-11-22 16:14:26 UTC
Thanks Hans.

Comment 40 Luya Tshimbalanga 2018-11-22 16:55 UTC
Created attachment 1508028 [details]
dmesg with rolledback bios

Bios is reverted and applied irqpool helped.  

cat /proc/interrupts | grep pinctrl_amd
   7:          0          0          0          0          0        712          0          0  IR-IO-APIC    7-fasteoi   pinctrl_amd

Comment 41 Luya Tshimbalanga 2018-11-22 16:58 UTC
Created attachment 1508029 [details]
Journal boot with rollback bios

Journal with rollback bios using irqpool

Comment 42 Luya Tshimbalanga 2018-11-22 16:59 UTC
Created attachment 1508030 [details]
Journal boot with rollback bios default paramaters

Comment 43 Hans de Goede 2018-11-22 17:11:04 UTC
I have the feeling that things work each time you change the BIOS version, this likely causes the GPIO chip to be reset to some default clean state.

And then in some later time things break again. Do you also have Windows on this machine?

What happens after you've booted Windows, do things become broken again?

If things become broken again, what happens if you power off the machine instead 
of just reboot?

What happens if you force power-off it by pressing the power-button for 6 seconds (4 usually does the trick, but it might be slightly longer) ?

Comment 44 Luya Tshimbalanga 2018-11-23 00:11 UTC
Created attachment 1508139 [details]
updated dmesg

(In reply to Hans de Goede from comment #43)
> I have the feeling that things work each time you change the BIOS version,
> this likely causes the GPIO chip to be reset to some default clean state.
> 
> And then in some later time things break again. Do you also have Windows on
> this machine?

Yes I have.


> What happens after you've booted Windows, do things become broken again?

No, they don't. Both touchscreen and stylus work out of box.

> If things become broken again, what happens if you power off the machine
> instead 
> of just reboot?

It took about four poweroff to gain touchscreen function.

dmesg | grep i2c
[    1.993157] psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
[    3.136597] i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vdd not found, using dummy regulator
[    3.136646] i2c_hid i2c-ELAN0732:00: Linked as a consumer to regulator.0
[    3.136648] i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vddl not found, using dummy regulator
[    3.163740] input: ELAN0732:00 04F3:264C Touchscreen as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input6
[    3.164303] input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input7
[    3.164367] input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input8
[    3.164448] input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input9
[    3.164569] hid-generic 0018:04F3:264C.0001: input,hidraw0: I2C HID v1.00 Device [ELAN0732:00 04F3:264C] on i2c-ELAN0732:00
[    3.324482] input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input12
[    3.324665] input: ELAN0732:00 04F3:264C Pen as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input15
[    3.324793] hid-multitouch 0018:04F3:264C.0001: input,hidraw0: I2C HID v1.00 Device [ELAN0732:00 04F3:264C] on i2c-ELAN0732:00

Previous attempt below:
 journalctl -b -1 --no-hostname | grep i2c
Nov 22 07:48:50 kernel: psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
Nov 22 07:48:50 kernel: i2c_hid i2c-ELAN0732:00: HID over i2c has not been provided an Int IRQ
Nov 22 07:48:50 kernel: i2c_hid: probe of i2c-ELAN0732:00 failed with error -22


It looks like poweroff properly assign the IRQ to i2c somehow. I haven't updated to the latest BIOS yet.

Additional note: 
Applying psmouse.synaptics_intertouch=1 allowed five fingers functions.

Comment 45 Luya Tshimbalanga 2018-11-23 03:16:57 UTC
Disregard the line about psmouse series as I accidently pasted it on the journalctl info.

Comment 46 Luya Tshimbalanga 2018-11-23 16:30:22 UTC
It looks like the IRQ 7 problem finally settles after gradually updating the BIOS:

cat /proc/interrupts | grep pinctrl_amd
   7:          0          0          0          0          0       1329          0          0  IR-IO-APIC    7-fasteoi   pinctrl_amd

cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.19.3-300.fc29.x86_64 root=UUID=607ff45d-a687-4c63-8fa3-359b27cee7bd ro resume=UUID=3d768890-e655-4465-90fd-8bf8c9e1209b rhgb quiet LANG=en_CA.UTF-8

Nov 23 00:17:11 kernel: DMI: HP HP ENVY x360 Convertible 15-cp0xxx/8497, BIOS F.21 10/19/2018


journalctl -b --no-hostname | grep i2c
Nov 23 00:17:11 kernel: psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
Nov 23 00:17:12 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vdd not found, using dummy regulator
Nov 23 00:17:12 kernel: i2c_hid i2c-ELAN0732:00: Linked as a consumer to regulator.0
Nov 23 00:17:12 kernel: i2c_hid i2c-ELAN0732:00: i2c-ELAN0732:00 supply vddl not found, using dummy regulator
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C Touchscreen as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input6
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input7
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input8
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input9
Nov 23 00:17:12 kernel: hid-generic 0018:04F3:264C.0001: input,hidraw0: I2C HID v1.00 Device [ELAN0732:00 04F3:264C] on i2c-ELAN0732:00
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input12
Nov 23 00:17:12 kernel: input: ELAN0732:00 04F3:264C Pen as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0732:00/0018:04F3:264C.0001/input/input15
Nov 23 00:17:12 kernel: hid-multitouch 0018:04F3:264C.0001: input,hidraw0: I2C HID v1.00 Device [ELAN0732:00 04F3:264C] on i2c-ELAN0732:00


It appears your suggestion to power off firs helps resolving the "disable IRQ#7".

Comment 47 Fedora Update System 2018-11-24 02:28:29 UTC
kernel-4.19.3-300.fc29, kernel-headers-4.19.3-300.fc29, kernel-tools-4.19.3-300.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 48 Fedora Update System 2018-11-27 17:12:27 UTC
kernel-4.19.3-200.fc28, kernel-headers-4.19.3-200.fc28, kernel-tools-4.19.3-200.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 49 Michael Eagle 2019-02-17 21:50:05 UTC
I still encounter the " Disable IRQ#7" issue:

[mike@localhost ~]$ journalctl -b --no-hostname | grep i2c
Feb 18 01:26:30 kernel: psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
Feb 18 01:26:30 kernel: i2c_hid i2c-ELAN0732:00: HID over i2c has not been provided an Int IRQ
Feb 18 01:26:30 kernel: i2c_hid: probe of i2c-ELAN0732:00 failed with error -22

[snip dmesg]
[    3.846882] Hardware name: HP HP ENVY x360 Convertible 15-cp0xxx/8497, BIOS F.32 12/10/2018
[    3.846883] Call Trace:
[    3.846885]  <IRQ>
[    3.846891]  dump_stack+0x5c/0x80
[    3.846895]  __report_bad_irq+0x35/0xa7
[    3.846897]  note_interrupt.cold+0xb/0x63
[    3.846898]  handle_irq_event_percpu+0x6f/0x80
[    3.846900]  handle_irq_event+0x28/0x48
[    3.846901]  handle_fasteoi_irq+0x7f/0x120
[    3.846904]  handle_irq+0xbf/0x100
[    3.846906]  do_IRQ+0x4b/0xe0
[    3.846908]  common_interrupt+0xf/0xf
[    3.846909]  </IRQ>
[    3.846912] RIP: 0010:cpuidle_enter_state+0xba/0x440
[    3.846914] Code: e8 3b 4a 96 ff 80 7c 24 0b 00 74 17 9c 58 0f 1f 44 00 00 f6 c4 02 0f 85 5e 03 00 00 31 ff e8 dd f9 9b ff fb 66 0f 1f 44 00 00 <45> 85 e4 0f 88 89 02 00 00 49 63 cc 4c 2b 2c 24 48 8d 04 49 48
 c1
[    3.846914] RSP: 0018:ffffac7e80da7e90 EFLAGS: 00000246 ORIG_RAX: ffffffffffffffdb
[    3.846916] RAX: ffff9cc158ba0fc0 RBX: ffffffffbd4d79a0 RCX: 000000000000001f
[    3.846917] RDX: 0000000000000000 RSI: 000000003a3dfa2f RDI: 0000000000000000
[    3.846917] RBP: ffff9cc150c88000 R08: 00000000e54a8ce5 R09: 0000000000000002
[    3.846918] R10: 000000073979c0f4 R11: ffff9cc158b9fe44 R12: 0000000000000002
[    3.846919] R13: 00000000e54a8ce5 R14: 0000000000000002 R15: ffffffffbd4d79a0
[    3.846922]  do_idle+0x1dd/0x260
[    3.846924]  cpu_startup_entry+0x19/0x20
[    3.846926]  start_secondary+0x1a7/0x200
[    3.846929]  secondary_startup_64+0xa4/0xb0
[    3.846930] handlers:
[    3.846933] [<00000000e2b221ba>] amd_gpio_irq_handler [pinctrl_amd]
[    3.846934] Disabling IRQ #7



[mike@localhost ~]$ cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-5.0.0-0.rc6.git1.2.fc30.x86_64 root=UUID=ea1bac65-713b-4027-a8f5-7535815ab9fb ro resume=UUID=28d396e8-65ef-46cc-81dd-45076af62215 rhgb quiet LANG=en_US.UTF-8

Comment 50 Luya Tshimbalanga 2019-04-05 08:06:23 UTC
(In reply to Hans de Goede from comment #23)
> BTW, I noticed the following message in your dmesg:
> 
> kernel: psmouse serio1: synaptics: Your touchpad (PNP: SYN3276 ETD0000
> PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not
> used, you might want to try setting psmouse.synaptics_intertouch to 1 and
> report this to linux-input@vger.kernel.org.
> 
> Can you try booting with psmouse.synaptics_intertouch=1 added to your kernel
> commandline and then run "dmesg > dmesg.txt" and attach dmesg.txt here ?
> 
> If your touchpad supports the RMI bus then that will lead to a better
> touchpad experience (sending coordinates for up-to 5 fingers when doing
> multi-touch instead of for just 2 fingers).

Adding psmouse.synaptics_intertouch=1 on boot with kernel 5.0.5 improve the touchpad experience.

dmesg | grep mouse
[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt7)/vmlinuz-5.0.5-300.fc30.x86_64 root=UUID=c8b8e2bf-1137-450e-a12a-17ec5fb708b8 ro resume=UUID=50edd0d0-2d4c-4314-9423-d20dc481b55b rhgb quiet plymouth.splash_delay=0 amdgpu.ppfeaturemask=0xffffbfff psmouse.synaptics_intertouch=1
[    0.213385] Kernel command line: BOOT_IMAGE=(hd0,gpt7)/vmlinuz-5.0.5-300.fc30.x86_64 root=UUID=c8b8e2bf-1137-450e-a12a-17ec5fb708b8 ro resume=UUID=50edd0d0-2d4c-4314-9423-d20dc481b55b rhgb quiet plymouth.splash_delay=0 amdgpu.ppfeaturemask=0xffffbfff psmouse.synaptics_intertouch=1
[    1.371301] mousedev: PS/2 mouse device common for all mice
[    2.088094] psmouse serio1: synaptics: queried max coordinates: x [..5638], y [..4736]
[    2.113844] psmouse serio1: synaptics: queried min coordinates: x [1302..], y [1114..]
[    2.113848] psmouse serio1: synaptics: Trying to set up SMBus access
[    2.116130] psmouse serio1: synaptics: SMbus companion is not ready yet
[    2.167003] psmouse serio1: synaptics: Touchpad model: 1, fw: 10.16, id: 0x1e2a1, caps: 0xf00423/0x840300/0x12e800/0x500000, board id: 3407, fw id: 2751673


Note You need to log in before you can comment on or make changes to this bug.