Bug 164403 - MySQL packages are installed despite the MySQL package group being deselected
MySQL packages are installed despite the MySQL package group being deselected
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 13:29 EDT by Dan Stangel
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 16:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Stangel 2005-07-27 13:29:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
RHEL4U1 installer installs MySQL version 4.1.7 and the mysqlclient10 packages even though the MySQL Database pacakge group is deselected (which is the default) during the installation process.

In addition, there are two instances of the mysql-4.1.7 package that get installed, so to remove them I have to use the 'rpm -e --allmatches' command.  Not sure if this is related or not.

This has been observed with the x86_64 RHEL4u1, have not tried with i386 version.  Testing was performed on an HP BL20p G3 blade; 


Version-Release number of selected component (if applicable):
mysql-4.1.7-5.RHEL4.1, mysqlclient10-3.23.58-4.RHEL4.1

How reproducible:
Always

Steps to Reproduce:
1. Begin a fresh RHEL4u1 installation on an x86_64 system
2. Make sure that the MySQL Database package selection is de-selected (default)
3. Observe that when the installation is complete, several mysql packages are now installed, despite step #2 above
  

Actual Results:  MySQL exists on the system when it should not.  This hinders future installation of binary RPM packages from mysql.com, for example.

Expected Results:  The installed system should not have MySQL installed

Additional info:
Comment 1 Jeremy Katz 2005-07-29 11:45:48 EDT
Some other packages are probably installed which require those library packages
(those are libs, not the servers).  If you run rpm --test -e mysql
libmysqlclient10, what does it tell you it can't remove them for?
Comment 2 Dan Stangel 2005-08-02 14:35:55 EDT
The db-related packages that appear to be installed by default are these:

[root@bic-b2 ~]# rpm -qa | grep -i sql
postgresql-libs-7.4.7-3.RHEL4.1
mysql-4.1.7-5.RHEL4.1
perl-DBD-MySQL-2.9004-3.1
mysqlclient10-3.23.58-4.RHEL4.1
cyrus-sasl-sql-2.1.19-5.EL4
[root@bic-b2 ~]#

The mysql package appears to be the actual mysql 4.1.7 client package: 
[root@bic-b2 ~]# rpm -qi mysql
Name        : mysql                        Relocations: (not relocatable)
Version     : 4.1.7                             Vendor: Red Hat, Inc.
Release     : 5.RHEL4.1                     Build Date: Fri 11 Feb 2005 01:50:03
PM MST
Install Date: Mon 13 Mar 2006 01:55:56 PM MST      Build Host:
tweety.build.redhat.com
Group       : Applications/Databases        Source RPM:
mysql-4.1.7-5.RHEL4.1.src.rpm
Size        : 5696466                          License: GPL
Signature   : DSA/SHA1, Tue 29 Mar 2005 03:48:37 PM MST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mysql.com
Summary     : MySQL client programs and shared library.
Description :
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. This package
contains the MySQL client programs, the client shared library, and
generic MySQL files.

This seems to be installed because of the following:
[root@bic-b2 ~]# rpm --test -e mysql
error: Failed dependencies:
        libmysqlclient.so.14 is needed by (installed) perl-DBD-MySQL-2.9004-3.1.i386
        libmysqlclient.so.14 is needed by (installed)
cyrus-sasl-sql-2.1.19-5.EL4.i386

Comment 3 Dan Stangel 2005-08-02 14:39:37 EDT
The db-related packages that appear to be installed by default are these:

[root@bic-b2 ~]# rpm -qa | grep -i sql
postgresql-libs-7.4.7-3.RHEL4.1
mysql-4.1.7-5.RHEL4.1
perl-DBD-MySQL-2.9004-3.1
mysqlclient10-3.23.58-4.RHEL4.1
cyrus-sasl-sql-2.1.19-5.EL4
[root@bic-b2 ~]#

The mysql package appears to be the actual mysql 4.1.7 client package: 
[root@bic-b2 ~]# rpm -qi mysql
Name        : mysql                        Relocations: (not relocatable)
Version     : 4.1.7                             Vendor: Red Hat, Inc.
Release     : 5.RHEL4.1                     Build Date: Fri 11 Feb 2005 01:50:03
PM MST
Install Date: Mon 13 Mar 2006 01:55:56 PM MST      Build Host:
tweety.build.redhat.com
Group       : Applications/Databases        Source RPM:
mysql-4.1.7-5.RHEL4.1.src.rpm
Size        : 5696466                          License: GPL
Signature   : DSA/SHA1, Tue 29 Mar 2005 03:48:37 PM MST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mysql.com
Summary     : MySQL client programs and shared library.
Description :
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. This package
contains the MySQL client programs, the client shared library, and
generic MySQL files.

This seems to be installed because of the following dependencies:
[root@bic-b2 ~]# rpm --test -e mysql
error: Failed dependencies:
        libmysqlclient.so.14 is needed by (installed) perl-DBD-MySQL-2.9004-3.1.i386
        libmysqlclient.so.14 is needed by (installed)
cyrus-sasl-sql-2.1.19-5.EL4.i386

However, the dependencies seem to be self-referential:
[root@bic-b2 ~]# rpm --test -e perl-DBD-MySQL
error: Failed dependencies:
        perl-DBD-MySQL is needed by (installed) mysql-4.1.7-5.RHEL4.1.i386
[root@bic-b2 ~]# rpm --test -e cyrus-sasl-sql
[root@bic-b2 ~]# rpm --test -e mysqlclient10
Comment 4 Jeremy Katz 2005-08-02 16:03:27 EDT
You selected to install the compatability arch support.  This includes a variety
of (i386) packages to provide a full x86 runtime environment.

Note You need to log in before you can comment on or make changes to this bug.