Bug 1644120 - Update database profile settings for gluster
Summary: Update database profile settings for gluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.4.z Batch Update 2
Assignee: Xavi Hernandez
QA Contact: Upasana
URL:
Whiteboard:
Depends On: 1631886
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-30 04:44 UTC by Sunil Kumar Acharya
Modified: 2018-12-17 17:07 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.12.2-27
Doc Type: If docs needed, set a value
Doc Text:
The database profile for GlusterFS has been updated to include changes that improve the performance for PostgreSQL workloads.
Clone Of: 1631886
Environment:
Last Closed: 2018-12-17 17:07:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3827 0 None None None 2018-12-17 17:07:27 UTC

Description Sunil Kumar Acharya 2018-10-30 04:44:03 UTC
+++ This bug was initially created as a clone of Bug #1631886 +++

Description of problem:

Database performance on gluster can be improved by enabling some additional options:

client-io-threads=on
open-behind=on
read-after-open=yes
server.event-threads=4
client.event-threads=4

The db profile group needs to be updated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-09-21 15:55:24 EDT ---

REVIEW: https://review.gluster.org/21247 (Update database profile group) posted (#1) for review on master by Xavi Hernandez

--- Additional comment from Worker Ant on 2018-09-24 13:56:18 EDT ---

COMMIT: https://review.gluster.org/21247 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- Update database profile group

Some performance testing has revealed that pgbench performs 3x better
when these options are set:

performance.client-io-threads=on
performance.open-behind=on
performance.read-after-open=yes
server.event-threads=4
client.event-threads=4

Change-Id: I36ce389f893a8af13aac5f8285104d749b73d098
fixes: bz#1631886
Signed-off-by: Xavi Hernandez <xhernandez@redhat.com>

Comment 2 Sunil Kumar Acharya 2018-10-30 05:04:08 UTC
Upstream Patch: https://review.gluster.org/21247

Comment 15 Anjana KD 2018-12-04 08:18:41 UTC
Updated the doc text. Kindly verify for technical accuracy.

Comment 16 Xavi Hernandez 2018-12-04 08:28:07 UTC
(In reply to Anjana from comment #15)
> Updated the doc text. Kindly verify for technical accuracy.

Made a minor change. Check if you think it's ok.

Comment 17 Anjana KD 2018-12-04 10:45:35 UTC
Noted, Thankyou.(In reply to Xavi Hernandez from comment #16)
> (In reply to Anjana from comment #15)
> > Updated the doc text. Kindly verify for technical accuracy.
> 
> Made a minor change. Check if you think it's ok.

Comment 18 errata-xmlrpc 2018-12-17 17:07:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3827


Note You need to log in before you can comment on or make changes to this bug.