Bug 1644152 - Add support of cloning 6.4 satellite
Summary: Add support of cloning 6.4 satellite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Satellite Clone
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.4.2
Assignee: Jonathon Turel
QA Contact: Nikhil Kathole
URL:
Whiteboard:
: 1624433 1666378 (view as bug list)
Depends On: 1664350
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-30 06:02 UTC by Nikhil Kathole
Modified: 2019-10-30 19:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 19:07:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github https://github.com/RedHatSatellite satellite-clone pull 346 None None None 2020-03-18 12:23:50 UTC
Red Hat Product Errata RHEA-2019:0344 None None None 2019-02-13 19:07:39 UTC

Description Nikhil Kathole 2018-10-30 06:02:54 UTC
Description of problem:
Its time to add support for 6.4 satellite clone.


Version-Release number of selected component (if applicable):
Satellite 6.5 snap1

satellite-clone-1.2.5-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1.satellite-clone -y

Actual results:
No support for 6.4

Expected results:


Additional info:

https://github.com/RedHatSatellite/satellite-clone/blob/master/library/parse_backup_metadata.py#L21

Comment 3 Ales Dujicek 2018-12-20 13:15:19 UTC
*** Bug 1624433 has been marked as a duplicate of this bug. ***

Comment 7 Mike McCune 2019-01-15 16:37:44 UTC
*** Bug 1666378 has been marked as a duplicate of this bug. ***

Comment 10 Nikhil Kathole 2019-01-25 08:51:57 UTC
VERIFIED

version tested:
Satellite 6.4.2 snap 1
satellite-clone-1.3.1-1.el7sat.noarch

Cloning satellite is successful but satellite-clone could not deal with a backup of the satellite having external databases.

The issue is tracked at https://bugzilla.redhat.com/show_bug.cgi?id=1669229

Comment 13 errata-xmlrpc 2019-02-13 19:07:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0344


Note You need to log in before you can comment on or make changes to this bug.