Bug 1644214 (CVE-2018-18584) - CVE-2018-18584 libmspack: Out-of-bounds write in mspack/cab.h
Summary: CVE-2018-18584 libmspack: Out-of-bounds write in mspack/cab.h
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-18584
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1644222 1644218 1644219 1644220 1644221 1648384
Blocks: 1644217
TreeView+ depends on / blocked
 
Reported: 2018-10-30 09:22 UTC by Andrej Nemec
Modified: 2019-09-29 15:01 UTC (History)
6 users (show)

Fixed In Version: libmspack 0.8, cabextract 1.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 19:19:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:2049 None None None 2019-08-06 12:07:30 UTC

Description Andrej Nemec 2018-10-30 09:22:53 UTC
In mspack/cab.h in libmspack before 0.8alpha and cabextract before 1.8, the CAB block input buffer is one byte too small for the maximal Quantum block, leading to an out-of-bounds write.

Upstream patch:

https://github.com/kyz/libmspack/commit/40ef1b4093d77ad3a5cfcee1f5cb6108b3a3bcc2

References:

https://www.openwall.com/lists/oss-security/2018/10/22/1

Comment 1 Andrej Nemec 2018-10-30 09:30:16 UTC
Created cabextract tracking bugs for this issue:

Affects: epel-all [bug 1644222]
Affects: fedora-all [bug 1644221]


Created libmspack tracking bugs for this issue:

Affects: epel-all [bug 1644219]
Affects: fedora-all [bug 1644218]

Comment 4 Stefan Cornelius 2018-11-09 15:12:49 UTC
Statement:

This issue affects the versions of libmspack as shipped with Red Hat Enterprise Linux 7.

Comment 8 errata-xmlrpc 2019-08-06 12:07:29 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2019:2049 https://access.redhat.com/errata/RHSA-2019:2049

Comment 9 Product Security DevOps Team 2019-08-06 19:19:54 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-18584


Note You need to log in before you can comment on or make changes to this bug.