Bug 1644268 - Review Request: mythes-eo - Esperanto thesaurus
Summary: Review Request: mythes-eo - Esperanto thesaurus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Robert-André Mauchin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-30 10:52 UTC by Carmen Bianca Bakker
Modified: 2019-05-02 03:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-27 21:27:48 UTC
zebob.m: fedora-review+


Attachments (Terms of Use)

Description Carmen Bianca Bakker 2018-10-30 10:52:54 UTC
Spec URL: https://www.carmenbianca.eu/mythes-eo.spec
SRPM URL: https://www.carmenbianca.eu/mythes-eo-0.20180330-1.fc29.src.rpm
Description: Esperanto thesaurus
Fedora Account System Username: carmenbianca

This is my first package, and I am seeking a sponsor.

Comment 1 Carmen Bianca Bakker 2018-10-30 14:15:19 UTC
I have a working Koji build here: https://koji.fedoraproject.org/koji/taskinfo?taskID=30559258

Took a little while to figure out how to work that.

Comment 2 Carmen Bianca Bakker 2018-10-31 12:27:21 UTC
I discovered that the source package also includes a hyphen file.  I've taken the liberty to also create a package for that.

Spec URL: https://www.carmenbianca.eu/hyphen-eo.spec
SRPM URL: https://www.carmenbianca.eu/hyphen-eo-0.20180330-1.fc29.src.rpm

I'm thinking it might make much more sense to condense the both of them into a single package, though, given that they share the same upstream.  But I wouldn't know how to call the parent package, or how to do that plumbing.

Ought I create a separate bug report for the hyphen package?

Comment 3 Carmen Bianca Bakker 2018-10-31 12:45:17 UTC
Figured out the plumbing.  This package created a `hyphen-eo` RPM and `mythes-eo` RPM without creating its own `super-eo` RPM.

Spec URL: https://www.carmenbianca.eu/super-eo.spec
SRPM URL: https://www.carmenbianca.eu/super-eo-0.20180330-1.fc29.src.rpm
Koji: https://koji.fedoraproject.org/koji/taskinfo?taskID=30573131

Comment 4 Artur Iwicki 2018-11-03 15:16:47 UTC
>pushd $RPM_BUILD_ROOT/%{_datadir}/hyphen/
>pushd $RPM_BUILD_ROOT/%{_datadir}/mythes/
Not needed.

Comment 5 Carmen Bianca Bakker 2018-11-08 07:52:49 UTC
(In reply to Artur Iwicki from comment #4)
> >pushd $RPM_BUILD_ROOT/%{_datadir}/hyphen/
> >pushd $RPM_BUILD_ROOT/%{_datadir}/mythes/
> Not needed.

Agreed.  I copied those by using other hyphen/mythes packages as template.

Comment 6 Parag AN(पराग) 2018-11-09 11:44:30 UTC
I will suggest use the mythes-eo as a package name instead of super-eo.

Remove following lines from spec file
pushd $RPM_BUILD_ROOT/%{_datadir}/hyphen/
pushd $RPM_BUILD_ROOT/%{_datadir}/mythes/

The license-en.txt contains text "or later" hence its GPLv3+ license tag.


Do you have any other package submitted for package review as well? To get sponsored you need to show your packaging skills either by submitting few packages and/or doing un-official package reviews of other people's submitted packages. See https://da.gd/o4gt for more information

Comment 7 Parag AN(पराग) 2018-11-23 03:53:42 UTC
Any updates here?

Comment 8 Carmen Bianca Bakker 2018-11-23 10:22:27 UTC
No updates yet due to a lack of time. I've been travelling. I should have more dispensible time now.

For clarity: I am not per se looking to become a general Fedora maintainer. I basically just want to get this super low-maintenance package into Fedora, and maintain it as need be.

As for renaming the package to mythes-eo: That will make hyphen-eo a subpackage of mythes-eo and thus explicitly depend on mythes-eo's dependencies, which is not desirable.  The best course of action then would be to maintain two separate packages, but that would be a little silly for a single upstream.

The package, as it's currently written, doesn't actually end up creating a super-eo package---only the two subpackages.

I'll soon submit two other (Python) packages I want to maintain, though.

Comment 9 Parag AN(पराग) 2018-11-23 14:47:23 UTC
Thanks for your quick reply.

I will drop myself from this review but if you need any help with this package review do write here.

About you point
(In reply to Carmen Bianca Bakker from comment #8)
> 
> As for renaming the package to mythes-eo: That will make hyphen-eo a
> subpackage of mythes-eo and thus explicitly depend on mythes-eo's
> dependencies, which is not desirable.  The best course of action then would
> be to maintain two separate packages, but that would be a little silly for a
> single upstream.

No that will not happen that way. e.g. See https://src.fedoraproject.org/rpms/hunspell-be/raw/master/f/hunspell-be.spec file. Do you think hyphen-be explicitly depend on hunspell-be's dependencies? No it will not. 

Just See,
$ rpm -q --requires hunspell-be
hunspell
$ rpm -q --requires hyphen-be
hyphen

Try installing hyphen-be only, I don't see hunspell will get installed.

Dependencies resolved.
===============================================================================
 Package           Arch           Version                 Repository      Size
===============================================================================
Installing:
 hyphen-be         noarch         1.1-16.fc29             fedora          11 k
Installing dependencies:
 hyphen            x86_64         2.8.8-10.fc29           fedora          29 k

Transaction Summary
===============================================================================
Install  2 Packages

Total size: 40 k
Installed size: 62 k
Downloading Packages:
[SKIPPED] hyphen-2.8.8-10.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] hyphen-be-1.1-16.fc29.noarch.rpm: Already downloaded                
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                       1/1 
Installed: hyphen-2.8.8-10.fc29.x86_64
  Installing       : hyphen-2.8.8-10.fc29.x86_64                           1/2 
  Running scriptlet: hyphen-2.8.8-10.fc29.x86_64                           1/2 
Installed: hyphen-2.8.8-10.fc29.x86_64
Installed: hyphen-be-1.1-16.fc29.noarch
  Installing       : hyphen-be-1.1-16.fc29.noarch                          2/2 
Installed: hyphen-be-1.1-16.fc29.noarch
  Running scriptlet: hyphen-be-1.1-16.fc29.noarch                          2/2 
  Verifying        : hyphen-2.8.8-10.fc29.x86_64                           1/2 
  Verifying        : hyphen-be-1.1-16.fc29.noarch                          2/2 

Installed:
  hyphen-be-1.1-16.fc29.noarch           hyphen-2.8.8-10.fc29.x86_64          



> 
> The package, as it's currently written, doesn't actually end up creating a
> super-eo package---only the two subpackages.

Yes. I can see that. As there is no %files section so main package named super-eo is not getting generated but only the subpackages binary rpms.

But I cannot find link/relation between the super-eo package name with mythes-eo or hyphen-eo packages.

Maybe some other Sponsor want to accept such super-eo package....

Comment 10 Carmen Bianca Bakker 2018-11-23 16:00:03 UTC
(In reply to Parag AN(पराग) from comment #9)
> No that will not happen that way. e.g. See
> https://src.fedoraproject.org/rpms/hunspell-be/raw/master/f/hunspell-be.spec
> file. Do you think hyphen-be explicitly depend on hunspell-be's
> dependencies? No it will not. 

Ah, erroneous assumption on my behalf then.

I've taken the suggestions and created a new package:

https://www.carmenbianca.eu/mythes-eo.spec
https://www.carmenbianca.eu/mythes-eo-0.20180330-2.fc29.src.rpm

Comment 11 Carmen Bianca Bakker 2018-11-24 11:34:33 UTC
Created another package at bug 1653010

Comment 12 David Tardon 2019-03-29 07:22:48 UTC
The oxt contains also a hunspell dictionary (files eo.dic and eo.aff). It would be nice to package that too.

Comment 13 Parag AN(पराग) 2019-03-29 08:19:21 UTC
The last time I saw this package, I noticed hunspell-eo srpm already exists in Fedora. Not sure if its still in Fedora or that package gets retired now like the mythes-de case. I also noticed that both the upstreams are different.

Comment 14 Carmen Bianca Bakker 2019-03-29 08:37:15 UTC
hunspell-eo already exists, but it appears to contain the exact same dictionary files (i.e., eo.aff and eo.dic), even though the upstreams are different. hunspell-eo has the original upstream for its dictionary files, which is <http://www.esperantilo.org/>. The upstream for this package appears to have repackaged those files.

I would probably keep hunspell-eo as-is.

Comment 15 Carmen Bianca Bakker 2019-04-20 07:06:41 UTC
I have become a packager, so this is no longer blocked by FE-NEEDSPONSOR.

Comment 16 Robert-André Mauchin 2019-04-21 08:19:36 UTC
Package approved.



Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "*No copyright* GPL (v2 or later) (with
     incorrect FSF address)". 11 files have unknown license. Detailed
     output of licensecheck in /home/bob/packaging/review/mythes-eo/review-
     mythes-eo/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in mythes-
     eo , hyphen-eo
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: mythes-eo-0.20180330-2.fc31.noarch.rpm
          hyphen-eo-0.20180330-2.fc31.noarch.rpm
          mythes-eo-0.20180330-2.fc31.src.rpm
3 packages and 0 specfiles checked; 0 errors, 0 warnings.

Comment 17 Igor Gnatenko 2019-04-22 07:00:10 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/mythes-eo

Comment 18 Fedora Update System 2019-04-23 08:05:25 UTC
mythes-eo-0.20180330-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-86dbba5108

Comment 19 Fedora Update System 2019-04-23 08:27:00 UTC
mythes-eo-0.20180330-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e88768bca3

Comment 20 Fedora Update System 2019-04-23 14:56:05 UTC
mythes-eo-0.20180330-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e88768bca3

Comment 21 Fedora Update System 2019-04-23 21:16:10 UTC
mythes-eo-0.20180330-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-86dbba5108

Comment 22 Fedora Update System 2019-04-27 21:27:48 UTC
mythes-eo-0.20180330-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2019-05-02 03:06:05 UTC
mythes-eo-0.20180330-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.