Bug 1644394 - Beast frontend fails to bind privileged ports with EACCES
Summary: Beast frontend fails to bind privileged ports with EACCES
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 3.2
Assignee: Casey Bodley
QA Contact: vidushi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-30 17:32 UTC by Casey Bodley
Modified: 2019-01-03 19:02 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-12.2.8-24.el7cp Ubuntu: ceph_12.2.8-22redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 36041 None None None 2018-10-30 17:32:17 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:22 UTC

Description Casey Bodley 2018-10-30 17:32:18 UTC
Description of problem:

When a privileged port number is given with rgw_frontends=beast, the frontend fails to bind with EACCES because radosgw has already dropped its permissions with setuid/setgid.


Version-Release number of selected component (if applicable):

RHCS 3.1

How reproducible:

Always

Steps to Reproduce:

1. Start radosgw with --rgw_frontends "beast port=80"

Actual results:

Radosgw fails to start with an error message:

> 2018-10-30 07:28:35.451529 7fe6b7badfc0  0 starting handler: beast
> 2018-10-30 07:28:35.452356 7fe6b7badfc0 -1 failed to bind address 10.8.128.74:443: Permission denied

Expected results:

Radosgw should defer its calls to setuid/setgid until the beast frontend is able to bind to these priveleged ports.

Additional info:

Comment 8 errata-xmlrpc 2019-01-03 19:02:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.