Bug 164441 - mock config allows changing basedir, but it's hardcoded
Summary: mock config allows changing basedir, but it's hardcoded
Status: CLOSED CANTFIX
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-27 21:44 UTC by Jeremy Katz
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:16:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2005-07-27 21:44:36 UTC
basedir is hardcoded into mock-helper so that people can't mount /proc
whereever.  But you can change basedir in the config file.

We should either make it so changing it in the config file then lets things work
or remove the option

Comment 1 Andrew Ziem 2006-04-04 02:36:28 UTC
I worked around the problem using a symlink, but an interim solution would be to
produce a warning to minimize confusion.

Comment 2 Clark Williams 2006-08-10 21:16:33 UTC
I'll add a snippet of code to check that configs['basedir'] is still
/var/lib/mock in the 0.6 code base. We've looked at this repeatedly and there's
just no safe way to change mock-helper. So for now bind-mounts is still the only
safe way to change where /var/lib/mock points. 

Shouldn't be an issue for the 0.7 codebase and up, since we removed mock-helper
and the setuid launcher just runs python on /usr/bin/mock.py



Note You need to log in before you can comment on or make changes to this bug.