Bug 1644483 - [4.0]Postcommithook failed with bundle: command not found when do building
Summary: [4.0]Postcommithook failed with bundle: command not found when do building
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-31 01:49 UTC by wewang
Modified: 2019-06-04 10:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Post commit hook was not being executed correctly after refactor to use dockerless builds Consequence: Certain configurations of post commit hooks would fail Fix: Corrected the way that post commit hooks were handled Result: It works correctly now
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:58 UTC

Description wewang 2018-10-31 01:49:17 UTC
Description of problem:
postcommithook failed with bundle: command not found when do building

Version-Release number of selected component (if applicable):
openshift v4.0.0-0.32.0

How reproducible:
always

Steps to Reproduce:
1.oc new-app --file=https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/templates/tc479059/application-template-parameters.json 

2.Check the log of build
Writing manifest to image destination Storing signatures --> da92d6ca45e7dc5607d604f66d35b56e44275824bff9b7ccec5164dbaa2f95fa STEP 11: FROM appimage8f2c4d8cdbe911e897a70a580a81001e STEP 12: RUN bundle exec rake test /bin/sh: bundle: command not found subprocess exited with status 127 subprocess exited with status 127 error: build error: error building at step {Env:[PATH=/opt/app-root/src/bin:/opt/app-root/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin SUMMARY=Platform for building and running Ruby 2.3 applications DESCRIPTION=Ruby 2.3 available as container is a base platform for building and running various Ruby 2.3 applications and frameworks. Ruby is the interpreted scripting language for quick and easy object-oriented programming. It has many features to process text files and to do system management tasks (as in Perl). It is simple, straight-forward, and extensible. STI_SCRIPTS_URL=image:///usr/libexec/s2i STI_SCRIPTS_PATH=/usr/libexec/s2i APP_ROOT=/opt/app-root HOME=/opt/app-root/src BASH_ENV=/opt/app-root/etc/scl_enable ENV=/opt/app-root/etc/scl_enable PROMPT_COMMAND=. /opt/app-root/etc/scl_enable NODEJS_SCL=rh-nodejs8 RUBY_VERSION=2.3 RACK_ENV=production OPENSHIFT_BUILD_NAME=ruby-sample-build-1 OPENSHIFT_BUILD_NAMESPACE=au10p OPENSHIFT_BUILD_SOURCE=git://github.com/openshift/ruby-hello-world.git OPENSHIFT_BUILD_COMMIT=7ccd3242c49c3868195ca9400a539fa611111096 EXAMPLE=sample-app] Command:run Args:[bundle exec rake test] Flags:[] Attrs:map[] Message:RUN bundle exec rake test Original:RUN bundle exec rake test}: exit status 127
3.

Actual results:
build failed 

Expected results:
build should success


Additional info:

Comment 1 wewang 2018-10-31 01:54:13 UTC
Corey Daley  gave a pr: https://github.com/openshift/origin/pull/21389, will test it today

Comment 2 wewang 2018-10-31 08:11:25 UTC
@Corey Daley  Tested these files it works now, Thanks for quick fix. and Status can  be changed to ON_QA.

Comment 3 wewang 2018-10-31 09:01:57 UTC
Fyi, pls help to merge to ose repo

Comment 4 Ben Parees 2018-10-31 12:48:56 UTC
> Fyi, pls help to merge to ose repo

origin PRs against master automatically merge to ose on the next ose build, that's why I moved it to modified after the origin PR merged.

Comment 7 errata-xmlrpc 2019-06-04 10:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.