Bug 164455 - Updater does not work after fresh installation
Updater does not work after fresh installation
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 19:07 EDT by aene@stanford.edu
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 18:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aene@stanford.edu 2005-07-27 19:07:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
No base channel is recognized by RHN for my computer and hence Icannot do any updates. This is a newer version of Dell and had a lot of problems with hardware not being recognized on install. After putting in a new hard drive and a new ethernet card, finally got the thing to install, now it won't update.
After registering with RHN, my system would appear twice in there, both with no Base Channel recognized.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. System Tools -> RHN
2. RHN Alert Icon -> Check for updates (352 waiting to be installed, message about up2daete version being older, duh! - this module is part of the install list)
3. Try to "Launch up2date"
4. Error message comes up, that I don't have a valid entitlement. I only have one product entitlement with registering my activation product ID and RHN shows two systems in there, all identical, except only one has the "Demo" entitlement (why???)
5. Go in RHN and delete the one system with the entitlement and update the entitlement to the remaining system (apparently the up2date was trying to run under the duplicate system registration, so I needed to give it the entitlement)
6. Now I only have one system registered in RHN, and get no more error case 31 about the entitlement, but the error that comes up is that "This system may not be updated until it is associated with a channel."
7. I am stuck, b/c there is no way I can get a base channel in RHN. Apparently this Red Hat Linux of yours doesn't run on anything but antiquated machines, because you guys cannop keep up with the newer hardware models :( I worked with my admin for 3 months just to install this and now cannot update. Will this take another year?

Actual Results:  Error... dismay!

Expected Results:  up2date shoul've installed all the updates

Additional info:
Comment 1 aene@stanford.edu 2005-08-12 18:11:16 EDT
As of yesterday 8/11, after booting up apparently a channel finally got assigned
to the computer, and was able to update the system, and also the network and
sound cards were finally recognized

Note You need to log in before you can comment on or make changes to this bug.