Bug 1644629 - [rpcsvc] Single request Queue for all event threads is a performance bottleneck
Summary: [rpcsvc] Single request Queue for all event threads is a performance bottleneck
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-31 09:36 UTC by Raghavendra G
Modified: 2019-03-25 16:31 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 19997 0 None Merged rpcsvc: provide each request handler thread its own queue 2018-11-29 01:19:48 UTC
Gluster.org Gerrit 21703 0 None Open libglusterfs: rename macros roof and floor to not conflict with math.h 2018-11-28 15:13:20 UTC

Description Raghavendra G 2018-10-31 09:36:39 UTC
Description of problem:

https://review.gluster.org/17105 brought in a change where requests are queued by event-threads and the queue is drained by rpcsvc-request-handler threads. With increasing server event threads, the single queue becomes a bottleneck due to contention involved in queueing and dequing requests. A better solution would be to let each pair of (event-thread, rpcsvc-request-handler-thread) to have its own queue to reduce contention.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-11-22 13:27:33 UTC
REVIEW: https://review.gluster.org/21703 (libglusterfs: rename macros roof and floor to not conflict with math.h) posted (#1) for review on master by Raghavendra G

Comment 2 Worker Ant 2018-11-28 15:13:19 UTC
REVIEW: https://review.gluster.org/21703 (libglusterfs: rename macros roof and floor to not conflict with math.h) posted (#19) for review on master by Raghavendra G

Comment 3 Worker Ant 2018-11-29 01:19:47 UTC
REVIEW: https://review.gluster.org/19997 (rpcsvc: provide each request handler thread its own queue) posted (#26) for review on master by Raghavendra G

Comment 4 Shyamsundar 2019-03-25 16:31:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.