Bug 164465 - kermit bombs when trying to ssh
Summary: kermit bombs when trying to ssh
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ckermit   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact:
URL: http://zeniv.linux.org.uk/~moo/bug1.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-28 01:09 UTC by Jason Duerstock
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 12:46:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I suggest to use openpty library. see #156417 (4.62 KB, application/octet-stream)
2005-07-29 10:19 UTC, Peter Vrabec
no flags Details

Description Jason Duerstock 2005-07-28 01:09:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
kermit bombs when trying to open ssh.  After further analysis, the problem comes up because there is no prototype for ptsname().  It should be included from <stdlib.h> but isn't because _XOPEN_SOURCE isn't #defined.  I'm not sure of the cleanest way to patch this because -D_XOPEN_SOURCE breaks some of the other source when you define it globally.  Another alternative is to make it use ttyname() instead of ptsname() but I'm not sure how to weave the #defines to make that happen.

Version-Release number of selected component (if applicable):
ckermit-8.0.211-1

How reproducible:
Always

Steps to Reproduce:
1. run kermit
2. ssh to localhost
3. wait for smoking ruin
  

Actual Results:  segmentation fault

Expected Results:  successful ssh connection

Additional info:

Comment 1 Peter Vrabec 2005-07-29 10:19:16 UTC
Created attachment 117266 [details]
I suggest to use openpty library. see #156417

Comment 2 Peter Vrabec 2005-08-01 12:46:16 UTC
FC4 update(ckermit-8.0.211-2.FC4) comming soon.


Note You need to log in before you can comment on or make changes to this bug.