Bug 1644653 - dnf duplicates "installed" line
Summary: dnf duplicates "installed" line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-31 10:38 UTC by Reverend Homer
Modified: 2018-12-05 02:33 UTC (History)
6 users (show)

Fixed In Version: dnf-4.0.9-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-05 02:33:20 UTC


Attachments (Terms of Use)

Description Reverend Homer 2018-10-31 10:38:53 UTC
Description of problem:

DNF duplicates "installed" line during installation of every package:

Running transaction
  Preparing        :                                                                                                                                                      1/1
Installed: ghc-terminfo-0.4.1.0-69.fc29.x86_64
  Installing       : ghc-terminfo-0.4.1.0-69.fc29.x86_64                                                                                                                 1/45
Installed: ghc-terminfo-0.4.1.0-69.fc29.x86_64
Installed: ghc-ghc-boot-8.2.2-69.fc29.x86_64
  Installing       : ghc-ghc-boot-8.2.2-69.fc29.x86_64                                                                                                                   2/45
Installed: ghc-ghc-boot-8.2.2-69.fc29.x86_64
Installed: ghc-ghci-8.2.2-69.fc29.x86_64
  Installing       : ghc-ghci-8.2.2-69.fc29.x86_64                                                                                                                       3/45
Installed: ghc-ghci-8.2.2-69.fc29.x86_64

As you can see, DNF writes "Installed: $pkgname" line twice: _before_ and after the installation

Version-Release number of selected component (if applicable):

λ dnf --version
4.0.4
  Installed: dnf-0:4.0.4-1.fc29.noarch at Tue 30 Oct 2018 21:17:49 GMT
  Built    : Fedora Project at Mon 15 Oct 2018 12:00:52 GMT

  Installed: rpm-0:4.14.2-1.fc29.x86_64 at Tue 30 Oct 2018 21:13:49 GMT
  Built    : Fedora Project at Wed 22 Aug 2018 08:07:47 GMT


How reproducible:

Always

Steps to Reproduce:
1. dnf install $any_package_name
2. wait for "Running transaction" line
3. observe

Actual results:

"Installed: $pkgname" is printed before and after the installation

Expected results:

"Installed: $pkgname" is printed once after the installation

Additional info:

Comment 1 Daniel Mach 2018-11-05 12:36:42 UTC
Fixed upstream : https://github.com/rpm-software-management/dnf/pull/1246

Comment 2 Fedora Update System 2018-11-22 18:56:45 UTC
libdnf-0.22.3-1.fc29 dnf-4.0.9-1.fc29 dnf-plugins-core-4.0.2-1.fc29 dnf-plugins-extras-4.0.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 3 Fedora Update System 2018-11-23 02:56:21 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 4 Reverend Homer 2018-11-26 06:25:41 UTC
It seems to be fixed, thank you

Comment 5 Fedora Update System 2018-12-05 02:33:20 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.