Bug 1644712 - The java package javafx.scene.control.* is missing on openjfx-8.0.152-17.b05.fc29
Summary: The java package javafx.scene.control.* is missing on openjfx-8.0.152-17.b05....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openjfx
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nicolas De Amicis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-31 13:06 UTC by Nicolas De Amicis
Modified: 2018-11-25 02:26 UTC (History)
10 users (show)

Fixed In Version: openjfx-8.0.152-19.b05.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-25 02:26:11 UTC
Type: Bug


Attachments (Terms of Use)
.spec file (6.34 KB, text/plain)
2018-11-07 14:33 UTC, Nicolas De Amicis
no flags Details
0001 patch (1.06 KB, patch)
2018-11-07 14:34 UTC, Nicolas De Amicis
no flags Details | Diff
0002 patch (3.97 KB, patch)
2018-11-07 14:37 UTC, Nicolas De Amicis
no flags Details | Diff
0003 patch (281 bytes, patch)
2018-11-07 14:37 UTC, Nicolas De Amicis
no flags Details | Diff
0004 patch (3.30 KB, patch)
2018-11-07 14:38 UTC, Nicolas De Amicis
no flags Details | Diff

Description Nicolas De Amicis 2018-10-31 13:06:02 UTC
Description of problem:
After migrating from F28 to F29, the rpm openjfx-8.0.152-17.b05.fc29 don't provide the java package javafx.scene.control.* but the same package for F28 (openjfx-8.0.152-12.b04.fc27)

Version-Release number of selected component (if applicable):
openjfx-8.0.152-17.b05.fc29

How reproducible:
Install openjfx and trying to compile or execute javafx application

Steps to Reproduce:
1.Install openjfx
2.Execute javafx application

Expected results:
update the package for F29 like the package F28

Comment 1 Jonny Heggheim 2018-10-31 17:58:50 UTC
Any ideas Mat Booth?

Comment 2 Mat Booth 2018-10-31 18:06:17 UTC
I'm afraid I don't know, I'm not the maintainer of this package.

In fact, this package appears to be orphaned so is likely to be dropped from the distro if no-one picks it up. If you have a fix feel free to take ownership of the package and fix it directly. I can sponsor you if you are not already a package maintainer :-)

Comment 3 Jonny Heggheim 2018-10-31 18:46:44 UTC
(In reply to Mat Booth from comment #2)
> I'm afraid I don't know, I'm not the maintainer of this package.

I know, I was hoping that you had some insight, since you did some changes to get it to build for f29.

> In fact, this package appears to be orphaned so is likely to be dropped from
> the distro if no-one picks it up. If you have a fix feel free to take
> ownership of the package and fix it directly. I can sponsor you if you are
> not already a package maintainer :-)

I orphaned it a while ago, due to that it takes too much time to maintain it.

Comment 4 Mat Booth 2018-11-01 13:32:15 UTC
I see.

If it makes your life easier, it looks like starting with openjfx 11 it is now available from maven central:

https://search.maven.org/classic/#artifactdetails|org.openjfx|javafx|11|pom

Comment 5 Nicolas De Amicis 2018-11-03 09:49:07 UTC
Ok, what should I do to become maintainer of this package?

Comment 6 Mat Booth 2018-11-05 11:05:22 UTC
(In reply to Nicolas De Amicis from comment #5)
> Ok, what should I do to become maintainer of this package?

Hi Nicolas!

First step, please submit a pull request: https://src.fedoraproject.org/rpms/openjfx

Are you a package maintainer already or do you need sponsorship?

Comment 7 Nicolas De Amicis 2018-11-05 12:48:07 UTC
Hi Mat, I'm working on a pull request. Currently I'm not package maintainer, I need sponsorship.

Comment 8 Mat Booth 2018-11-05 13:46:41 UTC
(In reply to Nicolas De Amicis from comment #7)
> Hi Mat, I'm working on a pull request. Currently I'm not package maintainer,
> I need sponsorship.

Cool. Once you submit the PR we can take a look and when it's ready I'll sponsor you into the group so you can commit it yourself.

As a sponsor I have to take "mentor" role so feel free to ask me anything and if I can't answer I can find where to get the answer :-)

Comment 9 Mat Booth 2018-11-05 14:10:13 UTC
I should mention there is some useful information about getting started with maintaining packages in the wiki here:

https://fedoraproject.org/wiki/Join_the_package_collection_maintainers

Comment 10 Nicolas De Amicis 2018-11-06 20:29:19 UTC
Hi, I'm trying to build the current package for understanding and I had to remove the xmvn instruction added by patch2. It's seems not working. I have another problem, I don't understand why when I run fedpkg --release f29 local, I have this error:
Could not resolve org.antlr:antlr:3.1.3.
  Required by:
      project :buildSrc
   > No cached version of org.antlr:antlr:3.1.3 available for offline mode.

Where is the offline cache? I have this jar in my maven local cache. I don't understand. Could you help me?

Comment 11 Nicolas De Amicis 2018-11-06 21:16:18 UTC
Well I generated a src rpm and rpms in various arch. For the PR, I commit the source rpm and/or the other rpms?

Comment 12 Jonny Heggheim 2018-11-06 22:40:05 UTC
(In reply to Nicolas De Amicis from comment #10)
> Where is the offline cache? I have this jar in my maven local cache. I don't
> understand. Could you help me?

xmvn needs all the build dependencies already installed before building local.

Try running:

> dnf builddep openjfx.spec

Comment 13 Nicolas De Amicis 2018-11-07 14:30:43 UTC
Hi Mat, I need your help. I don't create a PR on https://src.fedoraproject.org/rpms/openjfx, I haven't access to GIT (because I'm not member of Fedora Packager GIT Commit Group).
I put in attachment here the openjfx.spec, the patch files and other files. Please check my files or gives me access to GIT.
Thanks

Comment 14 Nicolas De Amicis 2018-11-07 14:33:16 UTC
Created attachment 1503009 [details]
.spec file

Comment 15 Nicolas De Amicis 2018-11-07 14:34:04 UTC
Created attachment 1503010 [details]
0001 patch

Comment 16 Nicolas De Amicis 2018-11-07 14:37:17 UTC
Created attachment 1503012 [details]
0002 patch

Comment 17 Nicolas De Amicis 2018-11-07 14:37:49 UTC
Created attachment 1503013 [details]
0003 patch

Comment 18 Nicolas De Amicis 2018-11-07 14:38:15 UTC
Created attachment 1503014 [details]
0004 patch

Comment 19 Nicolas De Amicis 2018-11-07 14:41:40 UTC
(In reply to Jonny Heggheim from comment #12)
> (In reply to Nicolas De Amicis from comment #10)
> > Where is the offline cache? I have this jar in my maven local cache. I don't
> > understand. Could you help me?
> 
> xmvn needs all the build dependencies already installed before building
> local.
> 
> Try running:
> 
> > dnf builddep openjfx.spec

Thanks Jonny, my problem is that i have installed gradle from sdkman.io and it seems that was the problem.

Comment 20 Mat Booth 2018-11-08 13:29:22 UTC
(In reply to Nicolas De Amicis from comment #13)
> Hi Mat, I need your help. I don't create a PR on
> https://src.fedoraproject.org/rpms/openjfx, I haven't access to GIT (because
> I'm not member of Fedora Packager GIT Commit Group).
> I put in attachment here the openjfx.spec, the patch files and other files.
> Please check my files or gives me access to GIT.
> Thanks

Are to able to fork the repo and push the change to your fork?

Comment 21 Bluexin 2018-11-20 15:02:56 UTC
Hello,

As a Fedora user I wanted to start getting involved in the project, so I figured this could be a nice place to start (<s>as I need the fix as well</s>).
Sadly I don't have enough free time to maintain the package (so am afraid to get involved into something too big for me. Baby steps!), but can manage the time to at least solve the current issues. Is it possible to do that without becoming the official maintainer of the package?

Comment 22 Nicolas De Amicis 2018-11-21 09:12:57 UTC
Hi, I'm maintainer of this package now. My Pull Request was merged. I'm learning how to push the fix into F29 updates.

Comment 23 Bluexin 2018-11-21 09:55:53 UTC
Alright, thank you very much for the hard work !

Comment 24 Fedora Update System 2018-11-21 12:03:47 UTC
openjfx-8.0.152-19.b05.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d43b6eaa3c

Comment 25 Fedora Update System 2018-11-22 05:38:09 UTC
openjfx-8.0.152-19.b05.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d43b6eaa3c

Comment 26 Radek Liboska 2018-11-22 07:35:08 UTC
Perfect!
openjfx-8.0.152-19.b05.fc29 is OK, thank you, my JabRef is working again!

Comment 27 Nicolas De Amicis 2018-11-22 08:04:40 UTC
Please provides your feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d43b6eaa3c
With feedback the update will be pushed to stable automatically with a karma of 3 (3 positives feedback)

Comment 28 Fedora Update System 2018-11-25 02:26:11 UTC
openjfx-8.0.152-19.b05.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.