Bug 164477 - Package is incorrectly named (confusing)
Package is incorrectly named (confusing)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mod_ssl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 01:13 EDT by Jason Bradley Nance
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 03:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Bradley Nance 2005-07-28 01:13:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20041013 Firefox/0.9.3 (Ubuntu)

Description of problem:
The "mod_ssl" that ships with RHEL isn't really mod_ssl (www.modssl.org) is it? Isn't it Apache-SSL (www.apache-ssl.org)?  I realize that there isn't a "mod_ssl" for Apache 2.0 and that it seems that in Apache 2.2 there is going to be an ASF "mod_ssl" (Apache-SSL renamed?), but right now this is all very confusing.  The rpm information points to httpd.apache.org for the URL, and the documentation on the ASF website seems to be cleaner/more complete, but wouldn't it make more sense to name the package httpd-ssl or something similar as to not add to the confusion?

Version-Release number of selected component (if applicable):
mod_ssl-2.0.52-12.1

How reproducible:
Always

Steps to Reproduce:
1. (clarity issue)
2.
3.
  

Additional info:
Comment 1 Joe Orton 2005-07-28 03:13:32 EDT
Thanks for contacting us.

The "mod_ssl" in httpd 2.0 is based on Ralf Engelschall's mod_ssl, so has a
legitimate claim to the name!  This FAQ entry describes the history:

http://httpd.apache.org/docs/2.0/ssl/ssl_faq.html#history

Note You need to log in before you can comment on or make changes to this bug.