Bug 164499 - Unable to mount loopback images from mounted GFS partition
Unable to mount loopback images from mounted GFS partition
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On: 187930
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:08 EDT by Jonathan Dieter
Modified: 2010-10-21 23:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0142
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 17:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow loopback (2.94 KB, patch)
2006-08-02 16:01 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Description Jonathan Dieter 2005-07-28 08:08:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I attempt to mount a filesystem image using -o loop that's stored on my GFS partition, it fails to mount (if it's ReiserFS) or mounts read-only (if it's EXT3).

Version-Release number of selected component (if applicable):
GFS-6.1.0-3

How reproducible:
Always

Steps to Reproduce:
1. Create EXT3 filesystem image or ReiserFS filesystem image in GFS directory
    a. $ dd if=/dev/zero of=/gfs/tempfs.img bs=1M count=1 seek=4096
    b. $ mke2fs -j -F /gfs/tempfs.img
         or
    c. $ mkreiserfs /gfs/tempfs.img
2. Attempt to mount filesystem (# mount -o loop /gfs/tempfs.img /mnt/temp)
  

Actual Results:  If the filesystem is ReiserFS, I got the error message:

mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

and /var/log/messages gives me:

Jul 28 14:31:12 server02 kernel: GFS: fsid=lesbg:world.0: warning: assertion "gfs_glock_is_locked_by_me(ip->i_gl)" failed
Jul 28 14:31:12 server02 kernel: GFS: fsid=lesbg:world.0:   function = gfs_prepare_write
Jul 28 14:31:12 server02 kernel: GFS: fsid=lesbg:world.0:   file = /usr/src/build/588748-i686/BUILD/xen0/src/gfs/ops_address.c, line = 329
Jul 28 14:31:12 server02 kernel: GFS: fsid=lesbg:world.0:   time = 1122550272
Jul 28 14:31:12 server02 kernel: Buffer I/O error on device loop0, logical block 8210
Jul 28 14:31:12 server02 kernel: lost page write due to I/O error on loop0
Jul 28 14:31:12 server02 kernel: ReiserFS: loop0: warning: journal-837: IO error during journal replay
Jul 28 14:31:12 server02 kernel: ReiserFS: loop0: warning: Replay Failure, unable to mount
Jul 28 14:31:12 server02 kernel: ReiserFS: loop0: warning: sh-2022: reiserfs_fill_super: unable to initialize journal space

If it's an EXT3 filesystem, it mounts, but only read-only, and I get the following in /var/log/messages:

Jul 28 14:33:56 server01 kernel: GFS: fsid=lesbg:world.1: warning: assertion "gfs_glock_is_locked_by_me(ip->i_gl)" failed
Jul 28 14:33:56 server01 kernel: GFS: fsid=lesbg:world.1:   function = gfs_prepare_write
Jul 28 14:33:56 server01 kernel: GFS: fsid=lesbg:world.1:   file = /usr/src/build/588748-i686/BUILD/xen0/src/gfs/ops_address.c, line = 329
Jul 28 14:33:56 server01 kernel: GFS: fsid=lesbg:world.1:   time = 1122550436
Jul 28 14:33:56 server01 kernel: Buffer I/O error on device loop1, logical block 259
Jul 28 14:33:56 server01 kernel: lost page write due to I/O error on loop1
Jul 28 14:35:02 server01 kernel: ext3_abort called.
Jul 28 14:35:02 server01 kernel: EXT3-fs error (device loop1): ext3_journal_start_sb: Detected aborted journal
Jul 28 14:35:02 server01 kernel: Remounting filesystem read-only

Expected Results:  The filesystem should mount rw, just like it does if I copy the .img file to any non-GFS location in the root filesystem

Additional info:
Comment 5 Robert Peterson 2006-08-02 16:01:30 EDT
Created attachment 133513 [details]
Patch to allow loopback

This is a patch to allow loopback mounting over GFS files.
It will only work if you have a newer loop.c in the kernel 
as described in bz 187930.
Comment 11 Red Hat Bugzilla 2007-05-10 17:12:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0142.html

Note You need to log in before you can comment on or make changes to this bug.