Bug 164504 - Automount not functional with driver restart
Automount not functional with driver restart
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike Christie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:35 EDT by Nitin Chandna
Modified: 2008-04-07 00:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 10:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nitin Chandna 2005-07-28 08:35:06 EDT
Description of problem:
Specified in /etc/fstab.iscsi the device to be automounted with syntax as follows:
/dev/sdb /mnt/sdb ext2 defaults 0 0
Started the Linux iscsi initiator.
Executed the command:
> mount
This does not display /dev/sdb mounted.
dmesg does show any errors
/var/log/messages does not show any error
Manual mount of /dev/sdb on /mnt/sdb works.
/mnt/sdb exists.
Auto-umounting also does not work:


Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Specified in /etc/fstab.iscsi the device to be automounted with syntax as
follows:
/dev/sdb /mnt/sdb ext2 defaults 0 0
2. Started the Linux iscsi initiator.
3. Executed the command:
> mount
This does not display /dev/sdb mounted.
dmesg does show any errors
/var/log/messages does not show any error
Manual mount of /dev/sdb on /mnt/sdb works.
/mnt/sdb exists.

4. Auto-umounting also does not work:
[root@linux-2 linux-iscsi-3.6.3]# /etc/init.d/iscsi stop
Stopping iSCSI: iscsidiscsi_sfnet: Device or resource busy
Unable to remove iscsi kernel driver - devices may still be in use

The device is visible in iscsi-ls -l command:
[root@linux-2 linux-iscsi-3.6.3]# iscsi-ls -l
*******************************************************************************
        SFNet iSCSI Driver Version ... 3.6.3 (27-Jun-2005 )
*******************************************************************************
TARGET NAME             : iqn.2004-04.com.cisco.cnitin-linux26-jbod-572d
TARGET ALIAS            : 
HOST NO                 : 2 
BUS NO                  : 0 
TARGET ID               : 19 
TARGET ADDRESS          : 10.1.1.80:3260
SESSION STATUS          : ESTABLISHED AT Tue Jul 26 22:18:45 2005
NO. OF PORTALS          : 1 
PORTAL ADDRESS 1        : 10.1.1.80:3260,12416
SESSION ID              : ISID 00023d000001 TSIH 3080

DEVICE DETAILS :
-------------- 
LUN ID : 0
  Vendor: SEAGATE  Model: ST318452FC       Rev: 0004
  Type:   Direct-Access                    ANSI SCSI revision: 04
  page83 type3: 20000004cf8c572d
  page80: 3345563036523245303030303732343144393657
  Device: /dev/sdb
*******************************************************************************
5. Now the driver is not stopping at all, unless every device is umounted.
Though entry is specified in /etc/fstab.iscsi. It is not getting umounted while
stopping the driver.

  
Actual results:
Mounting and umounting of the device does not work with the start and stop of
driver respectively.

Expected results:
With the start of the driver, device should get mounted automatically and with
the stop of driver, automatic unmount should happen as well, since this has been
specified in /etc/fstab.iscsi file.

Additional info:
Comment 1 AJ Lewis 2005-07-28 10:03:39 EDT
That's correct.  Look at the README for the iscsi-initiator-utils package. 
/etc/fstab.iscsi is not supported - you use the _netdev option in /etc/fstab for
iscsi mounts.  With this scheme, the netfs initscript, which is run after the
iscsi initscript on startup, and before it on shutdown, handles mounting and
unmounting of the _netdev devices.

Note You need to log in before you can comment on or make changes to this bug.