Bug 164518 - Shared data files removed on multilib systems
Summary: Shared data files removed on multilib systems
Status: CLOSED DUPLICATE of bug 140055
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-28 14:41 UTC by Jos Vos
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 18:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Session log for "rpm -evv zlib.i386" (6.15 KB, text/plain)
2005-10-26 13:05 UTC, Jos Vos
no flags Details

Description Jos Vos 2005-07-28 14:41:56 UTC
Description of problem:

When on 64-bit systems both the 32- and 64-bit versions of a package are
installed, removing the 32-bit version of the package also removes the shared
data files (e.g.  the /usr/shar/doc/... files), so the 64-bit version is left
with missing files.

Uninstalling all the i386 packages on a fully installed x86_64 RHEL4 system
results in about 4800 missing files in all the remaining x86_64 packages.

Version-Release number of selected component (if applicable):
4.3.3-9_nonptl

Comment 1 Paul Nasrat 2005-10-25 22:09:44 UTC
Jos can you confirm if the scope of the files removed is limited to:

/usr/share/zoneinfo
/usr/share/locale/
/usr/share/i18n
/usr/share/doc
/usr/lib/locale
/usr/src

I'm pretty sure I know what is causing this.  Also rpm -evv foo.i386 for a
single case would be useful to confirm my suspicion.

Comment 2 Jos Vos 2005-10-26 13:05:38 UTC
Created attachment 120412 [details]
Session log for "rpm -evv zlib.i386"

Comment 3 Jos Vos 2005-10-26 13:24:29 UTC
I can't confirm all your paths, but it is indeed limited to some paths, I think,
as I had the problem of missing several files in /usr/share when I had screwed
up a testsystem due to bug #170087, ended up with multiple versions of the same
package (same arch) and then removed the duplicate (oldest) versions. See my
attachment for the zlib trace on a decent system.

Comment 4 Paul Nasrat 2005-11-28 18:56:41 UTC

*** This bug has been marked as a duplicate of 140055 ***


Note You need to log in before you can comment on or make changes to this bug.