Bug 164523 - Add Blu Ray cdrom media support
Add Blu Ray cdrom media support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 11:10 EDT by Ralph Blach
Modified: 2011-02-02 09:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 09:52:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralph Blach 2005-07-28 11:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
The new Blu-ray cdrom 8gb media and Cdrom 8gb drives are not supported.
When I put a Blu-ray 8gb media and tried to use k3b, I got the message that 
the media was not supported.  Also,  when I was setting up to make DVD, k3b displayed of availble was 4gb and not 8gb as supported by the Blu-Ray DVD and Blu-Ray  media.

When making a DVD the program worked perfectly.

Chip



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Get a Blu-ray DVD writer with media
2.put a Blu-ray media into the CD writer
3.Try to burn an 8gb cdrom
  

Actual Results:  K3b reported bad media and an incorrect size.

Expected Results:  The cdtools should recognize the 8gb size and the Blu-ray media.

Additional info:

these are new in the market place, so I am not supprised this is not in the 
cd tools as of yet.  But, they will need to be supported.
Comment 1 Zachary Napora 2008-04-30 00:04:26 EDT
cdrtools has nearly full support for bluray, so k3b should be able to burn
it(but I don't think it does). So how well does fedora support bluray as of now?
Comment 2 Harald Hoyer 2008-04-30 04:39:13 EDT
we use cdrkit ... no cdrtools anymore because of License issues.
Comment 3 John Poelstra 2008-07-07 23:54:06 EDT
changed component re comment #2
Comment 4 Jörg Schilling 2009-01-24 17:25:10 EST
Please do not use cdrkit because of it's license issues.
cdrkit is in conflict with GPL and Copyright and cannot
be legally distributed.

The original software has no license issues, this has been 
aproved by the Sun Legal depatement.
Comment 5 shrek-m 2009-01-28 14:48:10 EST
this bug is open since 2005 ?

before i spend 200+ eur,
does fedora support Blu-Ray RE 25/50GB or not ?

if yes, how ?
cdrecord or dvdrecord or growisofs or ... ?
thanks.

--------
$ rpm -qf `which growisofs`
dvd+rw-tools-7.1-2.fc10.x86_64

$ rpm -qf `which cdrecord`
wodim-1.1.8-1.fc10.x86_64

--------
$ head /usr/share/doc/wodim-1.1.8/COPYING 
		    GNU GENERAL PUBLIC LICENSE
		       Version 2, June 1991

 Copyright (C) 1989, 1991 Free Software Foundation, Inc.
     59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 Everyone is permitted to copy and distribute verbatim copies
 of this license document, but changing it is not allowed.

			    Preamble

--------
http://cdrkit.org/
cdrkit, like the programs from which it was derived, is distributed as free software under the terms of the GNU GPL version 2. (Note, this is not "version 2 or later" as you see in many software projects.)

--------
apropos, does fedora support lightscribe ?
Comment 6 Jörg Schilling 2009-01-29 05:24:43 EST
The original cdrtools include BluRay support since July 2007.
You would need to tell RedHat to upgrade to the free original software.
Comment 7 shrek-m 2009-01-29 17:10:46 EST
A. @me
dvd+rw-tools has bluray support

http://fy.chalmers.se/~appro/linux/DVD+RW/Blu-ray/
... as of version 7.0 dvd+rw-tools support even Blu-ray Disc:-)



B. @redhat
please read
http://cdrecord.berlios.de/old/private/linux-dist.html


i had no problems with cdrecord between 2001 - ?2005/2006?
then my really bad cdrecord(clone) experiences started and i switched to growisofs and went never back.


could you compare once again both packages or
could it be possible to include both packages and change it with eg.
# alternatives --set cdrecord



thanks


--------
$ rpm -qf `which cdrecord` `which wodim`
wodim-1.1.8-1.fc10.x86_64
wodim-1.1.8-1.fc10.x86_64


$ wodim --version
Cdrecord-yelling-line-to-tell-frontends-to-use-it-like-version 2.01.01a03-dvd 
Wodim 1.1.8
Copyright (C) 2006 Cdrkit suite contributors
Based on works from Joerg Schilling, Copyright (C) 1995-2006, J. Schilling


$ cdrecord --version
Cdrecord-Clone 2.01 (cpu-pc-linux-gnu) Copyright (C) 1995-2004 J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
Comment 8 Fedora Admin XMLRPC Client 2011-01-10 08:23:22 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Honza Horak 2011-02-02 09:52:18 EST
There are many discussions about the license problem (e.g. bug 507108) and I can't say anything new. 

For your question about Lightscribe support in Fedora: there is no package supporting Lightscribe in official release, as far as I know. But there are several projects, that are not part of official release, and they are working properly in Fedora (e.g. http://fedorasolved.org/multimedia-solutions/lightscribe-for-linux).

Because the main question about Blu-Ray support is already answered (comment #7) and I think there is nothing else to discuss, I'm closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.