Bug 1645352 - Function Keys not working correctly on Dell XPS 15
Summary: Function Keys not working correctly on Dell XPS 15
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-desktop
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-02 03:02 UTC by Steevithak
Modified: 2019-11-27 20:23 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 20:23:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Steevithak 2018-11-02 03:02:02 UTC
Description of problem:
I installed Fedora 29 on a Dell XPS 15 laptop. The function keys are operating incorrectly. When I press a function key, I get the FN-function key operation and when I press a FN-function key combination I get the plain function key. 

For example if I press F3, I get a volume increase like I normally would if I pressed FN-F3 but when I try to increase the volume by pressing FN-F3, nothing happens. 

This is particularly troublesome when using software that requires frequent use of function keys, I have to continually add the FN key to get normal operation.

Version-Release number of selected component (if applicable):
Fedora 29

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 29 on a Dell XPS 15 laptop
2. Try to use a function key
3.

Actual results:
action will fail because the FN-function key action happens instead

Expected results:
pressing function results in function action
pressing FN-function results in FN-function action

Additional info:
I've used older version of Fedora on this laptop and I don't recall having this problem, so this seems to be a relatively recent bug. I did not use F28, so I don't know if the bug was present in that version.

Comment 1 JAlberto 2018-11-04 01:15:39 UTC
I have same issue in a XPS 9360

Comment 2 Dan Taylor 2018-11-17 03:20:59 UTC
XPS 13 2-in-1 same issue. Worked in F28.

Comment 3 Steevithak 2018-12-11 03:41:32 UTC
Has anyone found a fix or work around for this bug? It's making Fedora nearly unusable for me.

Comment 4 Steevithak 2018-12-15 23:56:14 UTC
Woo! Work-around found! If you press FN+ESC, it will reverse the current FN key lock status. I guess what's happening here is that Fedora is not setting (or resetting?) the FN lock status correctly during install on some laptops (just a guess). But the keyboard method of holding down FN and then hitting ESC seems to reverse it and the FN + Function key combos all worked normally again afterwards.

Comment 5 Ben Cotton 2019-10-31 20:18:35 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Ben Cotton 2019-11-27 20:23:00 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.