Bug 1645553 - Failed to get GBM bo for flip to new front... spamming forever on my logs
Summary: Failed to get GBM bo for flip to new front... spamming forever on my logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: https://gitlab.freedesktop.org/xorg/x...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-02 14:16 UTC by Douglas
Modified: 2019-07-09 02:17 UTC (History)
46 users (show)

Fixed In Version: xorg-x11-server-1.20.5-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-30 00:56:52 UTC


Attachments (Terms of Use)
Xorg logs (6.06 MB, text/plain)
2018-11-02 14:17 UTC, Douglas
no flags Details


Links
System ID Priority Status Summary Last Updated
Debian BTS 909041 None None None 2018-11-02 14:16:07 UTC

Description Douglas 2018-11-02 14:16:08 UTC
Description of problem:
[  1547.012] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[  1547.012] (EE) modeset(0): present flip failed

These lines are quickly being spammed onto my Xorg logs. I've attached the entire file so far.

Version-Release number of selected component (if applicable):
Nome         : xorg-x11-drv-intel
Versão       : 2.99.917

Nome         : xorg-x11-server-Xorg
Versão       : 1.20.2

How reproducible:
Always, from boot to shutdown, it starts spamming those lines into the logs.

Additional info:
- Running Fedora MATE-Compiz 29, fresh install, barely any changes or installed applications.

- A reboot did not solve the problem.

- Besides that, the system runs fine. But I worry my disk space will become a problem soon.

Comment 1 Douglas 2018-11-02 14:17:18 UTC
Created attachment 1500566 [details]
Xorg logs

Comment 2 宗伟 2018-11-05 10:08:40 UTC
same issue

$ uptime
 18:06:56 up  7:30,  2 users,  load average: 0.84, 0.76, 0.68
$ grep -o 'Failed to get GBM bo for flip to new front' /var/log/Xorg.0.log | wc -l
70441

Comment 3 Mat Martineau 2018-11-07 23:14:30 UTC
I'm also experiencing this bug with Fedora 29 and the MATE desktop. If I select Gnome when logging in, there is no problem.

It logs the same "Failed to get GBM bo for flip to new front" / "present flip failed" message pair 20x per second.

I see this on multiple computers, one with an Intel i7-6770HQ and one with an Intel i5-6260U.

Comment 4 Mat Martineau 2018-11-07 23:19:22 UTC
One more detail: both systems are using Intel integrated graphics with the i915 driver.

Comment 5 Chris Tao 2018-11-12 05:05:28 UTC
Can confirm this on xfwm and marco on f29. Both WMs now use the X Present Extension by default. Seems only Xorg 1.20 with modesetting DDX is affected.

Workarounds :

1) Switch to the intel DDX driver.

2) Disable page-flipping in the modesetting DDX or Xorg.

3) Start xfwm with "--vblank=glx". This disables XPresent support.

Comment 6 Milan Kerslager 2018-11-28 08:43:34 UTC
Any examples how to modify config files?

This prevent me to login to Xfce /etc/X11/xorg.conf.d/90-disable-page-flipping.conf:

Section "Device"
	Identifier "devname"
	Driver "modesetting"
	Option "PageFlip" off
EndSection

I found ~/.config/xfce4/xfwm4/ directory but don't know what to do next.

Comment 7 Frank McCormick 2018-12-21 03:54:42 UTC
Running Mate on Fedora 29 and this bug is filling up my drive.
Video is Intel 915

Is there a work around that works. Putting an xorg.conf in /etc/X11
prevents X from starting.

Comment 8 pkoz 2018-12-28 08:17:40 UTC
(In reply to Frank McCormick from comment #7)
> Running Mate on Fedora 29 and this bug is filling up my drive.
> Video is Intel 915
> 
> Is there a work around that works. Putting an xorg.conf in /etc/X11
> prevents X from starting.

Yes, I found something here:
https://community.parrotsec.org/t/self-reseting-to-loging-screen/3368/4
except that in may case the path is slightly different:
MATE menu>System>Prefrences>Look and Feel>Windows>General tab>Enable software compositing window manager checkbox.

Unticking the checkbox stops the message flood immediately.
Other side effects I could observe:
- only icons instead of thumbnail pictures when doing Alt-Tab window switching,
- the newly introduced icon flash-up when starting applications by the panel icons is not performed.

No other adverse effects in the past couple of hours in my environment.

That PageFlip business didn't work for me either.

Comment 9 Frank McCormick 2018-12-28 13:59:29 UTC
Thanks. That did it for me as well.

But I am still hoping for an Intel915 fix for this.

Comment 10 pkoz 2018-12-28 23:26:22 UTC
After all, I managed to turn off page flipping.
The trick was to hit upon the correct device identifier.
My conf file is:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "PageFlip" "off"
EndSection

Now, I don't know which workaround is better: turn off page flipping or disable the compositing window manager, I voted for the former.

BTW, I don't have installed the following packages on my system mentioned in this bug report:
xorg-x11-drv-modesetting (actually no such package exists in the Fedora repos)
xorg-x11-drv-intel

I do have only this:
xorg-x11-server-Xorg

Comment 11 Chris Tao 2018-12-29 03:35:14 UTC
(In reply to pkoz from comment #10)

> BTW, I don't have installed the following packages on my system mentioned in
> this bug report:
> xorg-x11-drv-modesetting (actually no such package exists in the Fedora
> repos)
> xorg-x11-drv-intel
> 
> I do have only this:
> xorg-x11-server-Xorg

The modesetting driver is now part of Xorg server:
$ rpm -qf /usr/lib64/xorg/modules/drivers/modesetting_drv.so 
xorg-x11-server-Xorg-1.20.3-2.fc29.x86_64

Also, switching to the intel DDX driver via the following conf file stops the error messages for me (I'm on xfwm 4.13):

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

Kwin, compton and xfwm4 with "--vblank=glx" doesn't produce such errors with default modesetting.

So I guess this is related to the Present extension and the modesetting driver. Should this bug be fired against xorg-x11-server-Xorg instead?

Comment 12 pkoz 2018-12-30 13:00:23 UTC
Yes, I suspect that no maintainer may pay any attention because of reference to this nonexistent component:
Component: 	xorg-x11-drv-modesetting (Show other bugs)

xorg-x11-server-Xorg would be better.
Who can change that? The original submitter?

Comment 13 Dominik 'Rathann' Mierzejewski 2018-12-31 18:38:57 UTC
I'm getting the same error message with modesetting driver. However, I'm forced to use the modesetting driver due to bug https://bugs.freedesktop.org/show_bug.cgi?id=109187 . Otherwise I get blank output on the external display (driven by nVidia GPU).

Comment 14 Dominik 'Rathann' Mierzejewski 2018-12-31 22:16:43 UTC
$ rpm -qf /usr/lib64/xorg/modules/drivers/modesetting_drv.so
xorg-x11-server-Xorg-1.20.3-2.fc29.x86_64

Comment 15 James Boyle 2019-01-02 18:58:22 UTC
Same issue for me. 

[  1264.004] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[  1264.004] (EE) modeset(0): present flip failed
[  1264.605] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[  1264.605] (EE) modeset(0): present flip failed
[  1265.206] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[  1265.206] (EE) modeset(0): present flip failed
[  1265.377] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[  1265.377] (EE) modeset(0): present flip failed


It's a F29 system with MATE.  The primary graphics card is a Radeon with two display port attached monitors @3840x2160

lspci |grep -i vga
04:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 41)
af:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon Pro WX 7100]

4.19.12-301.fc29.x86_64 #1 SMP Mon Dec 24 01:58:57 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux running on a dual CPU Sky Lake-E tower system.
xorg-x11-server-Xorg-1.20.3-2.fc29.x86_64

Comment 16 A. Galama 2019-01-17 09:36:07 UTC
Same issue for me on F29 with MATE.

# lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G96GL [Quadro FX 580] (rev a1)

# uname -r
4.19.15-300.fc29.x86_64

xorg-x11-server-Xorg-1.20.3-3.fc29.x86_64

The "Enable software compositing window manager checkbox" hack from comment 8 stops those messages but those fancy 3D-shadows around the windows disappeared.

Comment 17 Sergey Bostandzhyan 2019-01-27 13:26:04 UTC
(In reply to pkoz from comment #10)
> After all, I managed to turn off page flipping.
> The trick was to hit upon the correct device identifier.
> My conf file is:
> 
> Section "Device"
>     Identifier  "Intel Graphics"
>     Driver      "modesetting"
>     Option      "PageFlip" "off"
> EndSection

I had the same problem with i915 on an Acer Switch 10 notebook runnig MATE, the above setting solved the log spam problem, not sure about any visual implications yet.

Comment 18 lambda.xy.x 2019-01-30 01:33:10 UTC
I have the same problem on an Intel HD Graphics 630 (i915 driver) and xfce4.

Comment 19 Frank Ch. Eigler 2019-02-19 17:13:13 UTC
This is causing a 1.4 kilobyte/second (= 120 megabytes/day) append traffic to $HOME/.local/share/xorg/Xorg.0.log.  This problem is thus an i/o & storage consumption one too.

Comment 20 Marc Dionne 2019-02-19 19:27:22 UTC
Can the driver be changed to rate limit the offending messages, and/or stop trying the failing flip operation at some point.  Seems like that would be a fairly simple fix, to make the symptom less painful.

For now I've resorted to running a locally compiled modesetting_drv.so on my laptop where those error messages have just been commented out.

Comment 21 Chris Tao 2019-03-07 04:45:12 UTC
There is an upstream merge request for this: https://gitlab.freedesktop.org/xorg/xserver/merge_requests/131

Comment 22 John Dodson 2019-03-10 03:47:54 UTC
Me too (so I get on the cc)

Comment 23 Dominik 'Rathann' Mierzejewski 2019-03-19 22:55:17 UTC
David, could you pull the proposed fix into Fedora for downstream testing?

Comment 24 ivannovak90 2019-03-25 14:14:49 UTC
Same issue here
Fedora 29 with xfce4
Intel HD Graphics 520

Comment 25 Richard Myers 2019-04-02 23:16:35 UTC
Same issue here with XFCE Fedora 29, Intel i915 driver.  Not sure when the Xorg messages started, but I got involved when my display started freezing (mouse OK) after updating to Kernel 5.0.4.  Ctl-Alt F2 to a virtual terminal and Ctl-Alt F1 back fixes it, for a time.  I noticed the log spam while troubleshooting. Unchecking "Enable display compositing" in Window Manager Tweaks (from the XFCE Settings) stops the log messages.  I don't know yet whether it solves the screen freezes...

Comment 26 Richard Myers 2019-04-02 23:41:54 UTC
(In reply to Richard Myers from comment #25)
> Same issue here with XFCE Fedora 29, Intel i915 driver.  Not sure when the
> Xorg messages started, but I got involved when my display started freezing
> (mouse OK) after updating to Kernel 5.0.4.  Ctl-Alt F2 to a virtual terminal
> and Ctl-Alt F1 back fixes it, for a time.  I noticed the log spam while
> troubleshooting. Unchecking "Enable display compositing" in Window Manager
> Tweaks (from the XFCE Settings) stops the log messages.  I don't know yet
> whether it solves the screen freezes...

Just want to clarify ... "Ctl-Alt F2 to a virtual terminal and Ctl-Alt F1 back fixes it, for a time." fixes the frozen screen.  Not sure yet if the screen freezing has anything to do with this bug report.

Comment 27 markusN 2019-04-07 19:28:44 UTC
(In reply to Richard Myers from comment #25)
> I noticed the log spam while
> troubleshooting. Unchecking "Enable display compositing" in Window Manager
> Tweaks (from the XFCE Settings) stops the log messages.  I don't know yet
> whether it solves the screen freezes...

Thanks for the hint, also here unchecking "Enable display compositing" finally stopped the log messages.

Comment 28 Alfredo Ferrari 2019-04-21 07:50:53 UTC
same problem here, apart the log messages, since kernel 5.0.x the screen freezes randomly every 10-30 minutes (xfce4
with xorg), sometimes ctrl-alt-f2 ctrl-alt-f1 works to unfreeze, sometimes not

Comment 29 Philip Tait 2019-06-07 21:22:26 UTC
Still happening on XFCE Fedora 30, Intel i915 driver, kernel 5.1.5-300.fc30.x86_64.

Comment 30 William Bader 2019-06-14 21:47:41 UTC
I have been getting the modeset failed messages since updating from Fedora 28 to Fedora 30. I use the MATE desktop. I just found this bug report.
Unchecking the "Enable software compositing window manager" checkbox seems to have helped. Thanks to whomever discovered that.

I still get some other messages, but much less frequently.

Jun  9 00:29:49 scslaptop37 /usr/libexec/gdm-x-session[2772]: (II) Axis 0x1 value 1088 is outside expected range [1242, 4879]
Jun  9 00:29:49 scslaptop37 /usr/libexec/gdm-x-session[2772]: See https://wayland.freedesktop.org/libinput/doc/1.13.2/absolute_coordinate_ranges.html for details

Jun  9 04:16:25 scslaptop37 /usr/libexec/gdm-x-session[2772]: (II) Axis 0 value 1061 is outside expected range [1261, 5903]  
Jun  9 04:16:25 scslaptop37 /usr/libexec/gdm-x-session[2772]: See https://wayland.freedesktop.org/libinput/doc/1.13.2/absolute_coordinate_ranges.html for details  

Jun  9 16:48:17 scslaptop37 journal[1119]: Error looking up permission: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for geolocation
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: > Warning:          Unsupported maximum keycode 569, clipping. 
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: >                   X11 cannot support keycodes above 255.
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: > Internal error:   Could not resolve keysym XF86MonBrightnessCycle
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: > Internal error:   Could not resolve keysym XF86RotationLockToggle
Jun  9 16:48:17 scslaptop37 org.gnome.Shell.desktop[1119]: Errors from xkbcomp are not fatal to the X server
Jun  9 16:48:18 scslaptop37 journal[1119]: JS WARNING: [resource:///org/gnome/shell/ui/windowManager.js 1644]: reference to undefined property "MetaWindowXwayland"

Jun  9 18:28:56 scslaptop37 journal[1119]: Connection to xwayland lost
Jun  9 18:28:56 scslaptop37 journal[1275]: gsd-power: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jun  9 18:28:56 scslaptop37 gnome-session[1106]: gnome-session-binary[1106]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Jun  9 18:28:56 scslaptop37 gnome-session-binary[1106]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Jun  9 18:28:56 scslaptop37 gnome-session-binary[1106]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
Jun  9 18:28:56 scslaptop37 gnome-session[1106]: gnome-session-binary[1106]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1

Jun 14 22:34:29 scslaptop37 /usr/libexec/gdm-x-session[2392]: (II) Axis 0x1 value 991 is outside expected range [1242, 4879]
Jun 14 22:34:29 scslaptop37 /usr/libexec/gdm-x-session[2392]: See https://wayland.freedesktop.org/libinput/doc/1.13.2/absolute_coordinate_ranges.html for details

Jun 14 22:35:11 scslaptop37 kernel: [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
Jun 14 22:35:11 scslaptop37 kernel: [drm] PCIE GART of 1024M enabled (table at 0x0000000000162000).
Jun 14 22:35:11 scslaptop37 kernel: radeon 0000:01:00.0: WB enabled
Jun 14 22:35:11 scslaptop37 kernel: radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x00000000c7b3d8dc
Jun 14 22:35:11 scslaptop37 kernel: radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x0000000074eb37b3
Jun 14 22:35:11 scslaptop37 kernel: radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0x00000000c90f0d3b
Jun 14 22:35:11 scslaptop37 kernel: [drm] ring test on 0 succeeded in 2 usecs
Jun 14 22:35:11 scslaptop37 kernel: [drm] ring test on 3 succeeded in 8 usecs
Jun 14 22:35:11 scslaptop37 kernel: [drm] ring test on 5 succeeded in 2 usecs
Jun 14 22:35:11 scslaptop37 kernel: [drm] UVD initialized successfully.
Jun 14 22:35:11 scslaptop37 kernel: [drm] ib test on ring 0 succeeded in 0 usecs
Jun 14 22:35:11 scslaptop37 kernel: [drm] ib test on ring 3 succeeded in 0 usecs
Jun 14 22:35:12 scslaptop37 kernel: [drm] ib test on ring 5 succeeded

Here is some of my configuration:
$ rpm -q xorg-x11-server-Xorg
xorg-x11-server-Xorg-1.20.4-3.fc30.x86_64
$ uname -a
Linux scslaptop37.scs.com 5.1.8-300.fc30.x86_64 #1 SMP Sun Jun 9 17:09:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]

Comment 31 Chris Tao 2019-06-15 02:50:48 UTC
The fix has been merged upstream: https://gitlab.freedesktop.org/xorg/xserver/commit/26fe29f4fa53cbb7d51892e2cf397c084093812f
Hopefully this will be back-ported to xorg 1.20 branch. Otherwise default compositing in MATE and Xfce is broken since f29.

Comment 32 Fedora Update System 2019-06-28 17:15:23 UTC
FEDORA-2019-84694484f4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 33 Mat Martineau 2019-06-28 18:10:01 UTC
FEDORA-2019-84694484f4 (1.20.5) fixes the log spam with the MATE desktop in Fedora 30 for me.

Comment 34 Fedora Update System 2019-06-28 18:26:02 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 35 Chris Adams 2019-06-28 20:53:24 UTC
Will there be a build for F29?

Comment 36 Richard Myers 2019-06-28 22:27:33 UTC
(In reply to Chris Adams from comment #35)
> Will there be a build for F29?

I agree, we really need this for F29.  I notice it's not in the testing branch yet.  Upstream has fixed the issue with 1.20, and it's in testing for F30, so hopefully it's just a matter of time.  Wondering what the process is...? Is it an automatic thing (build for F29) or does it require a champion? https://bodhi.fedoraproject.org/users/ofourdan :) ?

Comment 37 Fedora Update System 2019-06-30 00:56:52 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 38 Stan King 2019-07-01 11:22:53 UTC
I concur with the utility of this improvement for Fedora 29.

Comment 39 Olivier Fourdan 2019-07-05 07:22:42 UTC
Unfortunately, I think we'll have to revert that change, it is causing regressions (bug 1725499)

Comment 40 Nerijus Baliūnas 2019-07-05 07:28:17 UTC
Is it possible to not spam logs at least then?

Comment 41 Dominik 'Rathann' Mierzejewski 2019-07-05 12:10:38 UTC
(In reply to Olivier Fourdan from comment #39)
> Unfortunately, I think we'll have to revert that change, it is causing
> regressions (bug 1725499)

Maybe not: https://gitlab.freedesktop.org/xorg/xserver/issues/842#note_186635 .

Comment 42 Kelly-Rand 2019-07-09 02:17:07 UTC
Please apply this patch to FC29.


Note You need to log in before you can comment on or make changes to this bug.