Bug 164567 - Open office "hangs" when trying to choose the java JRE VM
Open office "hangs" when trying to choose the java JRE VM
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 15:24 EDT by Edward Rudd
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 04:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 43103 None None None Never

  None (edit)
Description Edward Rudd 2005-07-28 15:24:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When trying to add a new Java VM, open office seems to hang and CPU usage spikes to 100%.  looking at the process output, it seems as though the java VM is being executed several times right in a row.

java -classpath /usr/lib/openoffice.org2.0/program/ JREProperties

running it manually it outputs a large series of numbers.

The same thing occurs on open office startup as well.

Version-Release number of selected component (if applicable):
1.9.117-3.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. open the tools / options menu
2. go into openoffice.org/java on the left
3. after a few minutes openoffice.org will start to respond again.
4. clicking the "Add" button will popup a gnome file dialog, which allows you to choose a JRE path, however any path chosen yeilds a "The folder you seleccted does not contain a Java runtime environment. Please select a different folder."

Additional info:

I have the x86_64 JDK 1.5.0_04 java RPM from Sun, along with the java-1.5.0-sun-compat package from jpackage 1.6 (for setting up the symlinks).
Comment 1 Edward Rudd 2005-07-28 15:36:23 EDT
Installing the i386 JVM along side the x86_64 vm and choosing the i386 version
resolves the issue, so OpenOffice no longer takes several minutes to start up. 
Though I don't see why openoffice should be executing the java JREProperties
command so many times when trying to detect the vms.
Comment 2 Caolan McNamara 2005-07-29 04:05:32 EDT
OOo is 32bit and requires 32bit support stuff. It will prefer sun java over gcj
if both are installed, so the problem is the 3rd party 64bit jvm being detected
and the attempt to use it not going well. You should report this problem to
openoffice.org where sun java is supported as FC does not support/provide sun
java. http://qa.openoffice.org/issues/show_bug.cgi?id=43103

Note You need to log in before you can comment on or make changes to this bug.