Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 164579 - OpenAFS and GPL-only exported kernel symbols
Summary: OpenAFS and GPL-only exported kernel symbols
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ernie Petrides
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-28 20:47 UTC by Issue Tracker
Modified: 2007-11-30 22:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 19:36:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Issue Tracker 2005-07-28 20:47:50 UTC
Escalated to Bugzilla from IssueTracker

Comment 12 Ernie Petrides 2005-08-30 19:36:44 UTC
I've investigated and reproduced the bug in the enforcement of the
GPL restriction on symbols exported from the main kernel.  (The bug
does not exist in symbols exported from kernel modules.)

There will never be a RHEL3 kernel fix for this GPL restriction
enforcement bug nor will the setting of CONFIG_MODVERSIONS be
changed.  The reasoning is that this would break compatibility
with 3rd-party modules.

Thus, OpenAFS is safe for the duration of RHEL3.

Closing as WONTFIX, which in this case is desirable by the bug reporter.




Note You need to log in before you can comment on or make changes to this bug.