Bug 16458 - tupo in /etc/rc.d/init.d/exim
tupo in /etc/rc.d/init.d/exim
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: exim (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-17 13:09 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 14:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-08-17 13:09:09 EDT
There is a problem with /etc/rc.d/init.d/exim
it has a return statement instead of exit

/etc/rc.d/init.d/exim start
Starting exim:                                             [  OK  ]
/etc/rc.d/init.d/exim: return: can only `return' from a function or sourced
script

Also should exim be upgraded to the lates stable exim-3.16
which has a number of bugs fixed.
Comment 1 Tim Powers 2000-08-17 14:17:35 EDT
Fixed. We can't update to that version this late in the game since there
wouldn't be much testing done with our package.

I removed the returns from the initscript.

Tim

Note You need to log in before you can comment on or make changes to this bug.