Bug 1645850 - Mesa 18.2.3 and above packaged by Fedora fails to compile some shaders
Summary: Mesa 18.2.3 and above packaged by Fedora fails to compile some shaders
Keywords:
Status: CLOSED DUPLICATE of bug 1645400
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 29
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-04 11:43 UTC by madcatx
Modified: 2018-11-05 10:44 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-05 10:44:47 UTC


Attachments (Terms of Use)

Description madcatx 2018-11-04 11:43:07 UTC
I noticed the problem even with Fedora 28 when I installed mesa-18.2.3 from a copr repository. At that time I treated it as a defect of the unofficial package. Now after the update to F29 I installed mesa-18.2.3 from "updates-testing" and it exhibits the very same problem. Attempts to bisect the issue did not get me anywhere because the issue does not seem to be a mesa issue. If I compile mesa -18.2.2 locally on my machine it misbehaves in exactly the same way as mesa-18.2.3. The only workaround for this issue is a downgrade to official mesa-18.2.2 packages. It would appear that some mesa dependency has changes at some point between mesa-18.2.2 and mesa-18.2.3 release and mesa packages built after this change are defective.

Relevant Freedesktop bugreport: https://bugs.freedesktop.org/show_bug.cgi?id=108646

Comment 1 Robert-André Mauchin 2018-11-04 12:41:56 UTC
Seems the culprit is gcc: compiled with gcc-8.2.1-2 it works, with gcc-8.2.1-4 it doesn't.

Comment 2 madcatx 2018-11-04 13:48:52 UTC
Confirmed. Rolling back to gcc-8.2.1-2 and rebuilding mesa (18.2.4 in my case) gets things back in order for me too. The amount of changes between the -2 and -4 releases seems to be too big for me to bisect this.

Comment 3 Robert-André Mauchin 2018-11-04 17:06:34 UTC
8.2.1-3 works. I'll try to svn-bisect the thingie. Why GNU isn't using GIT in 2018.

Comment 4 Dave Malcolm 2018-11-05 00:48:17 UTC
(In reply to Robert-André Mauchin from comment #3)
> 8.2.1-3 works. I'll try to svn-bisect the thingie. Why GNU isn't using GIT
> in 2018.

FWIW there's a git mirror of gcc svn:
  https://gcc.gnu.org/wiki/GitMirror

Comment 5 Jakub Jelinek 2018-11-05 10:44:47 UTC

*** This bug has been marked as a duplicate of bug 1645400 ***


Note You need to log in before you can comment on or make changes to this bug.