Bug 1645856 - There is a missing include, leading to a failure to use the library
Summary: There is a missing include, leading to a failure to use the library
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rxtx
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Levente Farkas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-04 12:13 UTC by Serge Droz
Modified: 2019-08-11 01:13 UTC (History)
3 users (show)

Fixed In Version: rxtx-2.2-0.24.20100211.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-11 01:13:25 UTC


Attachments (Terms of Use)
This patch fixes the problem (271 bytes, patch)
2018-11-04 12:13 UTC, Serge Droz
no flags Details | Diff

Description Serge Droz 2018-11-04 12:13:04 UTC
Created attachment 1501266 [details]
This patch fixes the problem

Description of problem:

Using the library an error is thrown:
java.lang.UnsatisfiedLinkError: /usr/lib64/rxtx/librxtxSerial-2.2pre1.so: /usr/lib64/rxtx/librxtxSerial-2.2pre1.so: undefined symbol: minor thrown while loading gnu.io.RXTXCommDriver
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: /usr/lib64/rxtx/librxtxSerial-2.2pre1.so: /usr/lib64/rxtx/librxtxSerial-2.2pre1.so: undefined symbol: minor


Version-Release number of selected component (if applicable):
rxtx-2.2-0.21.20100211.fc29.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Start BT747 
2. Try to connect
3.

Actual results:

Error

Expected results:

Connect to device

Additional info:
The bug is due to a missing include. A patch is appended. 
Essentially add to src/SerialImp.c

the line 

#include <sys/sysmacros.h>

Comment 1 Eric Lavarde 2019-01-26 17:10:20 UTC
I can confirm the issue (also using BT747). Actually, I thought that the better approach would be to package 2.2pre2 instead of 2.2pre1; this is also the version natively used by BT747.

The main problem with not being able to use Fedora's rxtx is that the version bundled with BT747 tries to get its lock in /var/lock (aka /run/lock, only writable by root) instead of /var/lock/lockdev (writable by group lock).

Comment 2 Fedora Update System 2019-08-02 14:02:19 UTC
FEDORA-2019-b336b4ee4b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b336b4ee4b

Comment 3 Fedora Update System 2019-08-03 00:58:21 UTC
rxtx-2.2-0.24.20100211.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b336b4ee4b

Comment 4 Fedora Update System 2019-08-11 01:13:25 UTC
rxtx-2.2-0.24.20100211.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.