Bug 1645897 - createrepo: posix_spawn avoided (fd close requested)
Summary: createrepo: posix_spawn avoided (fd close requested)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: createrepo_c
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jaroslav Rohel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1645741 1649224 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-04 18:40 UTC by Edgar Hoch
Modified: 2019-04-09 18:35 UTC (History)
12 users (show)

Fixed In Version: createrepo_c-0.11.1-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-17 19:12:14 UTC


Attachments (Terms of Use)

Description Edgar Hoch 2018-11-04 18:40:16 UTC
Description of problem:

$ umask 0002 ; /usr/bin/createrepo -q --update .
19:34:07: posix_spawn avoided (fd close requested) 
19:34:07: posix_spawn avoided (fd close requested) 
19:34:07: posix_spawn avoided (fd close requested) 
19:34:07: posix_spawn avoided (fd close requested) 


Version-Release number of selected component (if applicable):
createrepo_c-0.11.1-1.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Call "/usr/bin/createrepo -q --update ."
  in a directory where rpm files exist.


Actual results:
Messages: "posix_spawn avoided (fd close requested) "

Expected results:
No messages.

Comment 1 Miroslav Suchý 2018-11-05 15:12:32 UTC
*** Bug 1645741 has been marked as a duplicate of this bug. ***

Comment 2 Jaroslav Rohel 2018-11-09 07:31:48 UTC
New debug messages were added into GLib library. These messages come
from the "GLib" log domain and were not hidden in the standard and
quiet mode of the application.
This fix hides log messages regardless on source log domain.

PR: https://github.com/rpm-software-management/createrepo_c/pull/108

Comment 3 Jaroslav Rohel 2018-11-14 10:12:29 UTC
*** Bug 1649224 has been marked as a duplicate of this bug. ***

Comment 4 Julian Sikorski 2018-11-28 17:42:08 UTC
Could we get a fixed packaged pushed to F29 please? mockchain is broken without this fix. Thank you!

Comment 6 Richard Shaw 2018-12-09 19:44:22 UTC
Got tired of waiting and built my own package from the pull request and I can confirm it fixes the problem.

Comment 7 Fedora Update System 2018-12-13 11:29:50 UTC
createrepo_c-0.11.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cb91e6ac7b

Comment 8 Fedora Update System 2018-12-17 19:12:14 UTC
createrepo_c-0.11.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Frank Büttner 2019-03-31 17:18:00 UTC
On createrepo_c-0.12.2-1.fc29.x86_64 it will happens gain.

Comment 10 Nerijus Baliūnas 2019-04-01 14:42:55 UTC
/usr/bin/createrepo -q --update . works (does not print "posix_spawn avoided (fd close requested)" anymore), but mockchain fails:

$ mockchain -r epel-7-x86_64 -l /home/build/tmp /home/build/rpmbuild/SRPMS/nginx-module-geoip2-1.15.9-1.el7_4.ngx.src.rpm
starting logfile: None
results dir: /home/build/tmp/results/epel-7-x86_64
config dir: /home/build/tmp/configs/epel-7-x86_64
Error making local repo: /home/build/tmp/results/epel-7-x86_64
Err: 13:06:15: Version: 0.12.2 (Features: LegacyWeakdeps )
13:06:15: Signal handler setup
13:06:15: Thread pool ready

Comment 11 Richard Shaw 2019-04-09 18:35:32 UTC
Still having issues as well...

$ mockchain -r fedora-rawhide-x86_64 -l ./ ilmbase-2.3.0-1.fc31.src.rpm OpenEXR-2.3.0-1.fc31.src.rpm
starting logfile: None
results dir: /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64
config dir: /home/build/tmp/OpenEXR/configs/fedora-rawhide-x86_64
Error making local repo: /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64
Err: b"13:33:09: Version: 0.12.2 (Features: DeltaRPM LegacyWeakdeps )\n13:33:09: Signal handler setup\n13:33:09: Thread pool ready\n13:33:09: Dir to scan: /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64/.repodata\n13:33:09: Package count: 0\n13:33:09: No packages found - skipping metadata loading\n13:33:09: Creating .xml.gz files\n13:33:09: Setting number of packages\n13:33:09: Creating databases\n13:33:09: Thread pool user data ready\n13:33:09: Generating repomd.xml\n13:33:09: posix_spawn avoided (fd close requested) \n13:33:09: posix_spawn avoided (fd close requested) \n13:33:09: posix_spawn avoided (fd close requested) \n13:33:09: Old repodata doesn't exists: Cannot rename /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64/repodata/ -> /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64/repodata.old.11381.20190409133309.908235: No such file or directory\n13:33:09: Renamed /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64/.repodata/ -> /home/build/tmp/OpenEXR/results/fedora-rawhide-x86_64/repodata/\n13:33:09: Memory cleanup\n13:33:09: All done\n"


Note You need to log in before you can comment on or make changes to this bug.