Bug 1645987 - OpenStack playbook configures docker-storage-setup file after starting docker
Summary: OpenStack playbook configures docker-storage-setup file after starting docker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.z
Assignee: Tzu-Mainn Chen
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-05 06:21 UTC by Takayoshi Kimura
Modified: 2019-01-10 09:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-10 09:27:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0026 None None None 2019-01-10 09:27:16 UTC

Description Takayoshi Kimura 2018-11-05 06:21:59 UTC
Description of problem:

Version-Release number of the following components:

openshift-ansible-3.10.47-1.git.0.95bc2d2

How reproducible:

Always

Steps to Reproduce:
1. Run openstack playbook
2.
3.

Actual results:

The /etc/sysconfig/docker-storage-setup file will be created after starting docker service, so the storage configuration is not reflected. Next time reboot or restart docker service, it will be reflected.

Expected results:

Restart docker service after the /etc/sysconfig/docker-storage-setup file is configured. Or simply start docker only after the configuration.

Additional info:

Comment 4 Tzu-Mainn Chen 2018-11-05 21:24:54 UTC
PR for master: https://github.com/openshift/openshift-ansible/pull/10608

Comment 5 Tzu-Mainn Chen 2018-11-08 16:56:31 UTC
3.10 backport merged: https://github.com/openshift/openshift-ansible/pull/10632

Comment 12 weiwei jiang 2018-12-18 09:33:31 UTC
Checked with openshift-ansible-3.10.89-1 and docker work well.

[openshift@master-1 ~]$ sudo docker system info |grep -i Root
  WARNING: You're not using the default seccomp profile
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
Docker Root Dir: /var/lib/docker
[openshift@master-1 ~]$ df -h|grep -i docker 
/dev/mapper/docker--vol-dockerlv   15G  1.9G   14G  13% /var/lib/docker
[openshift@master-1 ~]$ sudo pvs
  PV         VG         Fmt  Attr PSize   PFree  
  /dev/vda2  rhel       lvm2 a--   <9.51g 736.00m
  /dev/vdb1  docker-vol lvm2 a--  <15.00g      0 
[openshift@master-1 ~]$ sudo lvs
  LV       VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  dockerlv docker-vol -wi-ao---- <15.00g                                                    
  root     rhel       -wi-ao----  <8.79g                                                    
[openshift@master-1 ~]$ sudo vgs
  VG         #PV #LV #SN Attr   VSize   VFree  
  docker-vol   1   1   0 wz--n- <15.00g      0 
  rhel         1   1   0 wz--n-  <9.51g 736.00m
[openshift@master-1 ~]$ cat /etc/sysconfig/docker-storage*
DOCKER_STORAGE_OPTIONS="--storage-driver overlay2 "
DEVS="/dev/vdb"
VG="docker-vol"
DATA_SIZE="95%VG"
STORAGE_DRIVER=overlay2
CONTAINER_ROOT_LV_NAME="dockerlv"
CONTAINER_ROOT_LV_MOUNT_PATH="/var/lib/docker"
CONTAINER_ROOT_LV_SIZE=100%FREE

Comment 14 errata-xmlrpc 2019-01-10 09:27:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0026


Note You need to log in before you can comment on or make changes to this bug.