Bug 164605 - kernel-smp panics on megaraid2 (dell 1850) - x86_64
kernel-smp panics on megaraid2 (dell 1850) - x86_64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia32e Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 04:27 EDT by Thomas Poindessous
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 16:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console capture of the kernel panic (89.38 KB, image/jpeg)
2005-07-29 04:29 EDT, Thomas Poindessous
no flags Details

  None (edit)
Description Thomas Poindessous 2005-07-29 04:27:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I got a Dell PowerEdge 1850, with a Perc 4e/Si RAID controller.

I installed rhel 3 U5 x86_64 version . With the uniproc kernel, this machine boots fine, but with the smp kernel, I got a kernel panic.



Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-32.0.1.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3_U5_x86_64
2. Boot the smp kernel
3. Kernel panics.
  

Additional info:
Comment 1 Thomas Poindessous 2005-07-29 04:29:00 EDT
Created attachment 117263 [details]
Console capture of the kernel panic
Comment 2 Dan Carpenter 2005-07-29 05:51:21 EDT
Can you boot with mem=2000m?

How much RAM do you have installed?  4G is the magic number so far as 64bit bugs go.

I saw this exact bug on a non-RedHat kernel earlier tonight with 4G EMT64 system.  

I used the mem= command line parameter to scrape 50 megs off the top and that
booted for me.  On my system because of the way the memory is laid out I guess,
I use mem=4600m and it shows that I have around 4G installed when I type free.

FC3 works on this system no problem.

Comment 3 Dan Carpenter 2005-07-29 05:57:00 EDT
BTW.  I used both the megaraid and the megaraid2 drivers and they both had the
same error with the pci_map_single.

Also can you configure IOMMU in your BIOS?  Sometimes you can.

I tried poking around with the iommu= boot params but that seemed like a voodoo
approach because I wasn't sure what I was doing.  For example, iommu=memaper=2
cuts down on the ammount of RAM available and it works but you may as well do
the mem= trick because it's cleaner.

Comment 4 Dan Carpenter 2005-07-29 06:16:31 EDT
The Dell PowerEdge 1850 is EMT64 as well.

This bug is similar to bug 160799 and bug 146199 except that for you it is the
install kernel that's goofing.

Install with mem=2000m and change to the correct kernel afterwards.

Let us know how that works out for you.
Comment 5 Ernie Petrides 2005-07-29 16:33:55 EDT
Use the correct (ia32e) RPM.

By the way, in U6 we've changed the panic you'll get when you do this
to use a message that is more explicit about what's wrong.  That's what
bug 160799 was about.

Note You need to log in before you can comment on or make changes to this bug.