Bug 164607 - chroot command fails with error from dynamic loader
chroot command fails with error from dynamic loader
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 04:37 EDT by Tim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 11:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim 2005-07-29 04:37:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Running chroot(1) generates an error from the loader:

# chroot /VS/lfs
Inconsistency detected by ld.so: rtld.c: 1221: dl_main: Assertion `pt_load_num || (void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!

Version-Release number of selected component (if applicable):
coreutils-5.2.1-31

How reproducible:
Always

Steps to Reproduce:
1.No special steps required. Just try to chroot to an existing directory
2.
3.
  

Actual Results:  Error message displayed

Expected Results:  Change to new root directory

Additional info:

The system is completely up to date with all packages installed via up2date and no custom compilation.

# uname -a
Linux slab 2.6.12-1.1372_FC3 #1 Fri Jul 15 00:59:10 EDT 2005 i686 i686 i386 GNU/Linux

The chroot is actually part of a script that sets various environment variables and was last known to have worked on July 15th, however executing chroot from the command bash line (as above) generates the same error.
Comment 1 Jakub Jelinek 2005-07-29 11:06:21 EDT
What glibc is installed in the chroot jail?
I very much doubt it is Fedora Core or RHEL glibc, for the following reason:
1) FC and RHEL glibc rpms are all built with -DNDEBUG=1, so assert is a nop,
   while you are triggering an assert in the code
2) pt_load_num is something that has lived in rtld.c from 2003-12-10 till
   2004-02-26, but FC3 original glibc is 2004-10-21 snapshot.
Yes, it is a bug, but a bug in whatever glibc you are using in the chroot.
Therefore complain to the distro from which it originates.
Comment 2 Leonard den Ottolander 2005-10-29 16:33:50 EDT
You can work around this problem by booting with the option vdso=0 (see
https://www.redhat.com/archives/fedora-list/2004-September/msg00559.html).

Note You need to log in before you can comment on or make changes to this bug.