Bug 1646164 - Dashboard url link (output of ansible task) is not opening in web browser
Summary: Dashboard url link (output of ansible task) is not opening in web browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Boris Ranto
QA Contact: Sunil Angadi
khartsoe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-05 09:50 UTC by Uday kurundwade
Modified: 2020-02-08 09:31 UTC (History)
9 users (show)

Fixed In Version: ceph-14.2.4
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshots of ansible output and host file (241.81 KB, application/zip)
2018-11-05 10:59 UTC, Uday kurundwade
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:06 UTC

Description Uday kurundwade 2018-11-05 09:50:39 UTC
Description of problem:
Dashboard url link is not opening in web browser

Version-Release number of selected component (if applicable):
ceph-common-12.2.8-23.el7cp.x86_64
ceph-ansible-3.2.0-0.1.beta9.el7cp.noarch
ceph-mgr-12.2.8-23.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install ceph storage by putting Full name (eg. magna123.ceph.redhat.com) for all nodes in /etc/ansible/hosts file
2.Install "dashboard v2" by running ansible playbook
3.Access dashboard page by clicking on url or copying url which is given in playbook output

Actual results:
Displays only short name of host which is not opening in url
Example : http://magna123:8234

Expected results:
It should display full FQDN with port number
Example : http://magna123.ceph.redhat.com:8234

Additional info:

Comment 3 Uday kurundwade 2018-11-05 10:59:30 UTC
Created attachment 1501782 [details]
Screenshots of ansible output and host file

Comment 4 Boris Ranto 2018-11-27 20:05:00 UTC
AFAIK, this should be fixed in the latest build:

http://file.rdu.redhat.com/~branto/dashboard-ansible-1.0-2.el7cp.noarch.rpm

Can you re-test, please?

Comment 5 Boris Ranto 2018-11-28 17:54:49 UTC
btw: You should always get fqdn (no matter what you specify in the ansible/hosts file) in the message with the latest build.

Comment 11 errata-xmlrpc 2020-01-31 12:44:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.